]> git.pld-linux.org Git - packages/qt5-qtsensors.git/blob - qt5-qtsensors.spec
up to 5.14.1
[packages/qt5-qtsensors.git] / qt5-qtsensors.spec
1 # maybe TODO: 
2 # plugins/simulator (BR: Qt5Simulator)
3 # plugins/sensorfw for MeeGo (sensorfw / sensord-qt)
4 #
5 # Conditional build:
6 %bcond_with     bootstrap       # disable features to able to build without installed qt5
7 %bcond_without  doc     # Documentation
8
9 %if %{with bootstrap}
10 %undefine       with_doc
11 %endif
12
13 %define         orgname         qtsensors
14 %define         qtbase_ver              %{version}
15 %define         qtdeclarative_ver       %{version}
16 %define         qttools_ver             5.8
17 Summary:        The Qt5 Sensors library
18 Summary(pl.UTF-8):      Biblioteka Qt5 Sensors
19 Name:           qt5-%{orgname}
20 Version:        5.14.1
21 Release:        1
22 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
23 Group:          X11/Libraries
24 Source0:        http://download.qt.io/official_releases/qt/5.14/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
25 # Source0-md5:  4f41f50fde6728ac91e6f55aa607702d
26 URL:            http://www.qt.io/
27 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
28 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
29 BuildRequires:  Qt5Quick-devel >= %{qtdeclarative_ver}
30 %if %{with doc}
31 BuildRequires:  qt5-assistant >= %{qttools_ver}
32 %endif
33 BuildRequires:  qt5-build >= %{qtbase_ver}
34 BuildRequires:  qt5-qmake >= %{qtbase_ver}
35 BuildRequires:  rpmbuild(macros) >= 1.654
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         specflags       -fno-strict-aliasing
41 %define         qt5dir          %{_libdir}/qt5
42
43 %description
44 Qt is a cross-platform application and UI framework. Using Qt, you can
45 write web-enabled applications once and deploy them across desktop,
46 mobile and embedded systems without rewriting the source code.
47
48 This package contains Qt5 Sensors library.
49
50 %description -l pl.UTF-8
51 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
52 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
53 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
54 źródłowego.
55
56 Ten pakiet zawiera bibliotekę Qt5 Sensors.
57
58 %package -n Qt5Sensors
59 Summary:        The Qt5 Sensors library
60 Summary(pl.UTF-8):      Biblioteka Qt5 Sensors
61 Group:          Libraries
62 Requires:       Qt5Core >= %{qtbase_ver}
63 Requires:       Qt5Qml >= %{qtdeclarative_ver}
64 Obsoletes:      qt5-qtsensors
65
66 %description -n Qt5Sensors
67 Qt5 Sensors library provides classes for reading sensor data.
68
69 %description -n Qt5Sensors -l pl.UTF-8
70 Biblioteka Qt5 Sensors dostarcza klasy do odczytu danych z czujników.
71
72 %package -n Qt5Sensors-devel
73 Summary:        Qt5 Sensors library - development files
74 Summary(pl.UTF-8):      Biblioteka Qt5 Sensors - pliki programistyczne
75 Group:          Development/Libraries
76 Requires:       Qt5Core-devel >= %{qtbase_ver}
77 Requires:       Qt5Sensors = %{version}-%{release}
78 Obsoletes:      qt5-qtsensors-devel
79
80 %description -n Qt5Sensors-devel
81 Qt5 Sensors library - development files.
82
83 %description -n Qt5Sensors-devel -l pl.UTF-8
84 Biblioteka Qt5 Sensors - pliki programistyczne.
85
86 %package doc
87 Summary:        Qt5 Sensors documentation in HTML format
88 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Sensors w formacie HTML
89 Group:          Documentation
90 Requires:       qt5-doc-common >= %{qtbase_ver}
91 %if "%{_rpmversion}" >= "5"
92 BuildArch:      noarch
93 %endif
94
95 %description doc
96 Qt5 Sensors documentation in HTML format.
97
98 %description doc -l pl.UTF-8
99 Dokumentacja do biblioteki Qt5 Sensors w formacie HTML.
100
101 %package doc-qch
102 Summary:        Qt5 Sensors documentation in QCH format
103 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Sensors w formacie QCH
104 Group:          Documentation
105 Requires:       qt5-doc-common >= %{qtbase_ver}
106 %if "%{_rpmversion}" >= "5"
107 BuildArch:      noarch
108 %endif
109
110 %description doc-qch
111 Qt5 Sensors documentation in QCH format.
112
113 %description doc-qch -l pl.UTF-8
114 Dokumentacja do biblioteki Qt5 Sensors w formacie QCH.
115
116 %package examples
117 Summary:        Qt5 Sensors examples
118 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Sensors
119 Group:          X11/Development/Libraries
120 %if "%{_rpmversion}" >= "5"
121 BuildArch:      noarch
122 %endif
123
124 %description examples
125 Qt5 Sensors examples.
126
127 %description examples -l pl.UTF-8
128 Przykłady do biblioteki Qt5 Sensors.
129
130 %prep
131 %setup -q -n %{orgname}-everywhere-src-%{version}
132
133 %build
134 qmake-qt5
135 %{__make}
136 %{?with_doc:%{__make} docs}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 %{__make} install \
141         INSTALL_ROOT=$RPM_BUILD_ROOT
142
143 %if %{with doc}
144 %{__make} install_docs \
145         INSTALL_ROOT=$RPM_BUILD_ROOT
146 %endif
147
148 # useless symlinks
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
150 # actually drop *.la, follow policy of not packaging them when *.pc exist
151 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
152
153 # Prepare some files list
154 ifecho() {
155         r="$RPM_BUILD_ROOT$2"
156         if [ -d "$r" ]; then
157                 echo "%%dir $2" >> $1.files
158         elif [ -x "$r" ] ; then
159                 echo "%%attr(755,root,root) $2" >> $1.files
160         elif [ -f "$r" ]; then
161                 echo "$2" >> $1.files
162         else
163                 echo "Error generation $1 files list!"
164                 echo "$r: no such file or directory!"
165                 return 1
166         fi
167 }
168 ifecho_tree() {
169         ifecho $1 $2
170         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
171                 ifecho $1 $2/$f
172         done
173 }
174
175 echo "%defattr(644,root,root,755)" > examples.files
176 ifecho_tree examples %{_examplesdir}/qt5/sensors
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   -n Qt5Sensors -p /sbin/ldconfig
182 %postun -n Qt5Sensors -p /sbin/ldconfig
183
184 %files -n Qt5Sensors
185 %defattr(644,root,root,755)
186 %doc LICENSE.GPL3-EXCEPT dist/changes-*
187 %attr(755,root,root) %{_libdir}/libQt5Sensors.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libQt5Sensors.so.5
189 %dir %{qt5dir}/plugins/sensorgestures
190 %attr(755,root,root) %{qt5dir}/plugins/sensorgestures/libqtsensorgestures_counterplugin.so
191 %attr(755,root,root) %{qt5dir}/plugins/sensorgestures/libqtsensorgestures_plugin.so
192 %attr(755,root,root) %{qt5dir}/plugins/sensorgestures/libqtsensorgestures_shakeplugin.so
193 %dir %{qt5dir}/plugins/sensors
194 %attr(755,root,root) %{qt5dir}/plugins/sensors/libqtsensors_generic.so
195 %attr(755,root,root) %{qt5dir}/plugins/sensors/libqtsensors_iio-sensor-proxy.so
196 %attr(755,root,root) %{qt5dir}/plugins/sensors/libqtsensors_linuxsys.so
197 %dir %{qt5dir}/qml/QtSensors
198 %attr(755,root,root) %{qt5dir}/qml/QtSensors/libdeclarative_sensors.so
199 %{qt5dir}/qml/QtSensors/plugins.qmltypes
200 %{qt5dir}/qml/QtSensors/qmldir
201
202 %files -n Qt5Sensors-devel
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/libQt5Sensors.so
205 %{_libdir}/libQt5Sensors.prl
206 %{_includedir}/qt5/QtSensors
207 %{_pkgconfigdir}/Qt5Sensors.pc
208 %{_libdir}/cmake/Qt5Sensors
209 %{qt5dir}/mkspecs/modules/qt_lib_sensors.pri
210 %{qt5dir}/mkspecs/modules/qt_lib_sensors_private.pri
211
212 %if %{with doc}
213 %files doc
214 %defattr(644,root,root,755)
215 %{_docdir}/qt5-doc/qtsensors
216
217 %files doc-qch
218 %defattr(644,root,root,755)
219 %{_docdir}/qt5-doc/qtsensors.qch
220 %endif
221
222 %files examples -f examples.files
223 %defattr(644,root,root,755)
224 # XXX: dir shared with qt5-qtbase-examples
225 %dir %{_examplesdir}/qt5
This page took 0.101036 seconds and 3 git commands to generate.