]> git.pld-linux.org Git - packages/qt5-qtsensors.git/blob - qt5-qtsensors.spec
- up to 5.3.2
[packages/qt5-qtsensors.git] / qt5-qtsensors.spec
1 # maybe TODO: 
2 # plugins/simulator (BR: Qt5Simulator)
3 # plugins/sensorfw for MeeGo (sensorfw / sensord-qt)
4 #
5 # Conditional build:
6 %bcond_without  qch     # documentation in QCH format
7
8 %define         orgname         qtsensors
9 %define         qtbase_ver              %{version}
10 %define         qtdeclarative_ver       %{version}
11 %define         qttools_ver             %{version}
12 Summary:        The Qt5 Sensors library
13 Summary(pl.UTF-8):      Biblioteka Qt5 Sensors
14 Name:           qt5-%{orgname}
15 Version:        5.3.2
16 Release:        1
17 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
18 Group:          X11/Libraries
19 Source0:        http://download.qt-project.org/official_releases/qt/5.3/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
20 # Source0-md5:  d0a8dc3173bfc9dc9f2632d509a76e6f
21 URL:            http://qt-project.org/
22 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
23 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
24 BuildRequires:  Qt5Quick-devel >= %{qtdeclarative_ver}
25 %if %{with qch}
26 BuildRequires:  qt5-assistant >= %{qttools_ver}
27 %endif
28 BuildRequires:  qt5-build >= %{qtbase_ver}
29 BuildRequires:  qt5-qmake >= %{qtbase_ver}
30 BuildRequires:  rpmbuild(macros) >= 1.654
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         specflags       -fno-strict-aliasing
36 %define         qt5dir          %{_libdir}/qt5
37
38 %description
39 Qt is a cross-platform application and UI framework. Using Qt, you can
40 write web-enabled applications once and deploy them across desktop,
41 mobile and embedded systems without rewriting the source code.
42
43 This package contains Qt5 Sensors library.
44
45 %description -l pl.UTF-8
46 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
47 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
48 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
49 źródłowego.
50
51 Ten pakiet zawiera bibliotekę Qt5 Sensors.
52
53 %package -n Qt5Sensors
54 Summary:        The Qt5 Sensors library
55 Summary(pl.UTF-8):      Biblioteka Qt5 Sensors
56 Group:          Libraries
57 Requires:       Qt5Core >= %{qtbase_ver}
58 Requires:       Qt5Qml >= %{qtdeclarative_ver}
59 Obsoletes:      qt5-qtsensors
60
61 %description -n Qt5Sensors
62 Qt5 Sensors library provides classes for reading sensor data.
63
64 %description -n Qt5Sensors -l pl.UTF-8
65 Biblioteka Qt5 Sensors dostarcza klasy do odczytu danych z czujników.
66
67 %package -n Qt5Sensors-devel
68 Summary:        Qt5 Sensors library - development files
69 Summary(pl.UTF-8):      Biblioteka Qt5 Sensors - pliki programistyczne
70 Group:          Development/Libraries
71 Requires:       Qt5Core-devel >= %{qtbase_ver}
72 Requires:       Qt5Sensors = %{version}-%{release}
73 Obsoletes:      qt5-qtsensors-devel
74
75 %description -n Qt5Sensors-devel
76 Qt5 Sensors library - development files.
77
78 %description -n Qt5Sensors-devel -l pl.UTF-8
79 Biblioteka Qt5 Sensors - pliki programistyczne.
80
81 %package doc
82 Summary:        Qt5 Sensors documentation in HTML format
83 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Sensors w formacie HTML
84 Group:          Documentation
85 Requires:       qt5-doc-common >= %{qtbase_ver}
86 %if "%{_rpmversion}" >= "5"
87 BuildArch:      noarch
88 %endif
89
90 %description doc
91 Qt5 Sensors documentation in HTML format.
92
93 %description doc -l pl.UTF-8
94 Dokumentacja do biblioteki Qt5 Sensors w formacie HTML.
95
96 %package doc-qch
97 Summary:        Qt5 Sensors documentation in QCH format
98 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Sensors w formacie QCH
99 Group:          Documentation
100 Requires:       qt5-doc-common >= %{qtbase_ver}
101 %if "%{_rpmversion}" >= "5"
102 BuildArch:      noarch
103 %endif
104
105 %description doc-qch
106 Qt5 Sensors documentation in QCH format.
107
108 %description doc-qch -l pl.UTF-8
109 Dokumentacja do biblioteki Qt5 Sensors w formacie QCH.
110
111 %package examples
112 Summary:        Qt5 Sensors examples
113 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Sensors
114 Group:          X11/Development/Libraries
115 %if "%{_rpmversion}" >= "5"
116 BuildArch:      noarch
117 %endif
118
119 %description examples
120 Qt5 Sensors examples.
121
122 %description examples -l pl.UTF-8
123 Przykłady do biblioteki Qt5 Sensors.
124
125 %prep
126 %setup -q -n %{orgname}-opensource-src-%{version}
127
128 %build
129 qmake-qt5
130 %{__make}
131 %{__make} %{!?with_qch:html_}docs
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 %{__make} install \
136         INSTALL_ROOT=$RPM_BUILD_ROOT
137
138 %{__make} install_%{!?with_qch:html_}docs \
139         INSTALL_ROOT=$RPM_BUILD_ROOT
140
141 # useless symlinks
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
143 # actually drop *.la, follow policy of not packaging them when *.pc exist
144 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
145
146 # Prepare some files list
147 ifecho() {
148         r="$RPM_BUILD_ROOT$2"
149         if [ -d "$r" ]; then
150                 echo "%%dir $2" >> $1.files
151         elif [ -x "$r" ] ; then
152                 echo "%%attr(755,root,root) $2" >> $1.files
153         elif [ -f "$r" ]; then
154                 echo "$2" >> $1.files
155         else
156                 echo "Error generation $1 files list!"
157                 echo "$r: no such file or directory!"
158                 return 1
159         fi
160 }
161 ifecho_tree() {
162         ifecho $1 $2
163         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
164                 ifecho $1 $2/$f
165         done
166 }
167
168 echo "%defattr(644,root,root,755)" > examples.files
169 ifecho_tree examples %{_examplesdir}/qt5/qtsensors
170 ifecho_tree examples %{_examplesdir}/qt5/sensors
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -n Qt5Sensors -p /sbin/ldconfig
176 %postun -n Qt5Sensors -p /sbin/ldconfig
177
178 %files -n Qt5Sensors
179 %defattr(644,root,root,755)
180 %doc LGPL_EXCEPTION.txt dist/changes-*
181 %attr(755,root,root) %{_libdir}/libQt5Sensors.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libQt5Sensors.so.5
183 %dir %{qt5dir}/plugins/sensorgestures
184 %attr(755,root,root) %{qt5dir}/plugins/sensorgestures/libqtsensorgestures_counterplugin.so
185 %attr(755,root,root) %{qt5dir}/plugins/sensorgestures/libqtsensorgestures_plugin.so
186 %attr(755,root,root) %{qt5dir}/plugins/sensorgestures/libqtsensorgestures_shakeplugin.so
187 %dir %{qt5dir}/plugins/sensors
188 %attr(755,root,root) %{qt5dir}/plugins/sensors/libqtsensors_dummy.so
189 %attr(755,root,root) %{qt5dir}/plugins/sensors/libqtsensors_generic.so
190 %attr(755,root,root) %{qt5dir}/plugins/sensors/libqtsensors_linuxsys.so
191 %dir %{qt5dir}/qml/QtSensors
192 %attr(755,root,root) %{qt5dir}/qml/QtSensors/libdeclarative_sensors.so
193 %{qt5dir}/qml/QtSensors/plugins.qmltypes
194 %{qt5dir}/qml/QtSensors/qmldir
195
196 %files -n Qt5Sensors-devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libQt5Sensors.so
199 %{_libdir}/libQt5Sensors.prl
200 %{_includedir}/qt5/QtSensors
201 %{_pkgconfigdir}/Qt5Sensors.pc
202 %{_libdir}/cmake/Qt5Sensors
203 %{qt5dir}/mkspecs/modules/qt_lib_sensors.pri
204 %{qt5dir}/mkspecs/modules/qt_lib_sensors_private.pri
205
206 %files doc
207 %defattr(644,root,root,755)
208 %{_docdir}/qt5-doc/qtsensors
209
210 %if %{with qch}
211 %files doc-qch
212 %defattr(644,root,root,755)
213 %{_docdir}/qt5-doc/qtsensors.qch
214 %endif
215
216 %files examples -f examples.files
217 %defattr(644,root,root,755)
218 # XXX: dir shared with qt5-qtbase-examples
219 %dir %{_examplesdir}/qt5
This page took 0.041266 seconds and 3 git commands to generate.