]> git.pld-linux.org Git - packages/qt5-qtscxml.git/blob - qt5-qtscxml.spec
- new
[packages/qt5-qtscxml.git] / qt5-qtscxml.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtscxml
6 %define         qtbase_ver              %{version}
7 %define         qtdeclarative_ver       %{version}
8 %define         qttools_ver             %{version}
9 Summary:        The Qt5 Scxml library
10 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml
11 Name:           qt5-%{orgname}
12 Version:        5.15.2
13 Release:        1
14 License:        LGPL v3 or GPL v2+ or commercial
15 Group:          X11/Libraries
16 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
17 # Source0-md5:  5c52fd3e39707e46c6a37b4e13636ceb
18 URL:            https://www.qt.io/
19 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
21 %if %{with doc}
22 BuildRequires:  qt5-assistant >= %{qttools_ver}
23 BuildRequires:  qt5-doc-common >= %{qttools_ver}
24 %endif
25 BuildRequires:  qt5-build >= %{qtbase_ver}
26 BuildRequires:  qt5-qmake >= %{qtbase_ver}
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  rpmbuild(macros) >= 1.752
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         specflags       -fno-strict-aliasing
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Qt is a cross-platform application and UI framework. Using Qt, you can
38 write web-enabled applications once and deploy them across desktop,
39 mobile and embedded systems without rewriting the source code.
40
41 This package contains Qt5 Scxml library.
42
43 %description -l pl.UTF-8
44 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
45 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
46 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
47 źródłowego.
48
49 Ten pakiet zawiera bibliotekę Qt5 Scxml.
50
51 %package -n Qt5Scxml
52 Summary:        The Qt5 Scxml library
53 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml
54 Group:          X11/Libraries
55 Requires:       Qt5Core >= %{qtbase_ver}
56 Requires:       Qt5Gui >= %{qtbase_ver}
57 Requires:       Qt5Qml >= %{qtdeclarative_ver}
58 Requires:       Qt5Quick >= %{qtdeclarative_ver}
59
60 %description -n Qt5Scxml
61 Qt5 Scxml library.
62
63 %description -n Qt5Scxml -l pl.UTF-8
64 Biblioteka Qt5 Scxml.
65
66 %package -n Qt5Scxml-devel
67 Summary:        Qt5 Scxml - development files
68 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml - pliki programistyczne
69 Group:          X11/Development/Libraries
70 Requires:       Qt5Core-devel >= %{qtbase_ver}
71 Requires:       Qt5Gui-devel >= %{qtbase_ver}
72
73 %description -n Qt5Scxml-devel
74 Qt5 Scxml - development files.
75
76 %description -n Qt5Scxml-devel -l pl.UTF-8
77 Biblioteka Qt5 Scxml - pliki programistyczne.
78
79 %package doc
80 Summary:        Qt5 Scxml documentation in HTML format
81 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Scxml w formacie HTML
82 Group:          Documentation
83 Requires:       qt5-doc-common >= %{qtbase_ver}
84 BuildArch:      noarch
85
86 %description doc
87 Qt5 Scxml documentation in HTML format.
88
89 %description doc -l pl.UTF-8
90 Dokumentacja do biblioteki Qt5 Scxml w formacie HTML.
91
92 %package doc-qch
93 Summary:        Qt5 Scxml documentation in QCH format
94 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Scxml w formacie QCH
95 Group:          Documentation
96 Requires:       qt5-doc-common >= %{qtbase_ver}
97 BuildArch:      noarch
98
99 %description doc-qch
100 Qt5 Scxml documentation in QCH format.
101
102 %description doc-qch -l pl.UTF-8
103 Dokumentacja do biblioteki Qt5 Scxml w formacie QCH.
104
105 %package examples
106 Summary:        Qt5 Scxml examples
107 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Scxml
108 Group:          X11/Development/Libraries
109 BuildArch:      noarch
110
111 %description examples
112 Qt5 Scxml examples.
113
114 %description examples -l pl.UTF-8
115 Przykłady do biblioteki Qt5 Scxml.
116
117 %prep
118 %setup -q -n %{orgname}-everywhere-src-%{version}
119
120 %build
121 qmake-qt5
122 %{__make}
123 %{?with_doc:%{__make} docs}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         INSTALL_ROOT=$RPM_BUILD_ROOT
130
131 %if %{with doc}
132 %{__make} install_docs \
133         INSTALL_ROOT=$RPM_BUILD_ROOT
134 %endif
135
136 # useless symlinks
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
138 # obsoleted by pkg-config
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
140
141 # remove compiled examples (package only sources)
142 for d in $RPM_BUILD_ROOT%{_examplesdir}/qt5/scxml/* ; do
143         [ -d "$d" ] && %{__rm} "$d/$(basename $d)"
144 done
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -n Qt5Scxml -p /sbin/ldconfig
150 %postun -n Qt5Scxml -p /sbin/ldconfig
151
152 %files -n Qt5Scxml
153 %defattr(644,root,root,755)
154 %doc LICENSE.GPL3-EXCEPT dist/changes-*
155 # R: Qt5Core Qt5Qml
156 %attr(755,root,root) %{_libdir}/libQt5Scxml.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libQt5Scxml.so.5
158 # R: Qt5Core
159 %attr(755,root,root) %{qt5dir}/bin/qscxmlc
160 %dir %{qt5dir}/qml/QtScxml
161 # R: Qt5Core Qt5Qml Qt5Scxml
162 %attr(755,root,root) %{qt5dir}/qml/QtScxml/libdeclarative_scxml.so
163 %{qt5dir}/qml/QtScxml/plugins.qmltypes
164 %{qt5dir}/qml/QtScxml/qmldir
165
166 %files -n Qt5Scxml-devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libQt5Scxml.so
169 %{_libdir}/libQt5Scxml.prl
170 %{_includedir}/qt5/QtScxml
171 %{_pkgconfigdir}/Qt5Scxml.pc
172 %{_libdir}/cmake/Qt5Scxml
173 %{qt5dir}/mkspecs/features/qscxmlc.prf
174 %{qt5dir}/mkspecs/modules/qt_lib_scxml.pri
175 %{qt5dir}/mkspecs/modules/qt_lib_scxml_private.pri
176
177 %if %{with doc}
178 %files doc
179 %defattr(644,root,root,755)
180 %{_docdir}/qt5-doc/qtscxml
181
182 %files doc-qch
183 %defattr(644,root,root,755)
184 %{_docdir}/qt5-doc/qtscxml.qch
185 %endif
186
187 %files examples
188 %defattr(644,root,root,755)
189 # XXX: dir shared with qt5-qtbase-examples
190 %dir %{_examplesdir}/qt5
191 %{_examplesdir}/qt5/scxml
This page took 0.097338 seconds and 3 git commands to generate.