]> git.pld-linux.org Git - packages/qt5-qtquick1.git/blob - qt5-qtquick1.spec
noarch -doc, -examples; tar.xz deps
[packages/qt5-qtquick1.git] / qt5-qtquick1.spec
1 # TODO:
2 # - cleanup
3
4 %define         orgname         qtquick1
5 Summary:        The Qt5 Quick1
6 Name:           qt5-%{orgname}
7 Version:        5.2.0
8 Release:        0.1
9 License:        LGPL v2.1 or GPL v3.0
10 Group:          X11/Libraries
11 Source0:        http://download.qt-project.org/official_releases/qt/5.2/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
12 # Source0-md5:  4535ff78b5a9a18ffba702298a48e22e
13 URL:            http://qt-project.org/
14 BuildRequires:  qt5-qtbase-devel = %{version}
15 BuildRequires:  qt5-qtdeclarative-devel = %{version}
16 BuildRequires:  qt5-qtscript-devel = %{version}
17 BuildRequires:  qt5-qttools-devel = %{version}
18 BuildRequires:  qt5-qtxmlpatterns-devel = %{version}
19 BuildRequires:  rpmbuild(macros) >= 1.654
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
25 %define         _noautostrip    '.*_debug\\.so*'
26
27 %define         specflags       -fno-strict-aliasing
28 %define         _qtdir          %{_libdir}/qt5
29
30 %description
31 Qt5 Quick1 libraries.
32
33 %package devel
34 Summary:        The Qt5 Quick1 - development files
35 Group:          X11/Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Qt5 Quick1 - development files.
40
41 %package doc
42 Summary:        The Qt5 Quick1 - docs
43 Group:          Documentation
44 %if "%{_rpmversion}" >= "5"
45 BuildArch:      noarch
46 %endif
47
48 %description doc
49 Qt5 Quick1 - documentation.
50
51 %package examples
52 Summary:        Qt5 Quick1 examples
53 Group:          X11/Development/Libraries
54 %if "%{_rpmversion}" >= "5"
55 BuildArch:      noarch
56 %endif
57
58 %description examples
59 Qt5 Quick1 - examples.
60
61 %prep
62 %setup -q -n %{orgname}-opensource-src-%{version}
63
64 %build
65 qmake-qt5
66 %{__make}
67 %{__make} docs
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 %{__make} install \
72         INSTALL_ROOT=$RPM_BUILD_ROOT
73
74 %{__make} install_docs \
75         INSTALL_ROOT=$RPM_BUILD_ROOT
76
77 # Prepare some files list
78 ifecho() {
79         RESULT=`echo $RPM_BUILD_ROOT$2 2>/dev/null`
80         [ "$RESULT" == "" ] && return # XXX this is never true due $RPM_BUILD_ROOT being set
81         r=`echo $RESULT | awk '{ print $1 }'`
82
83         if [ -d "$r" ]; then
84                 echo "%%dir $2" >> $1.files
85         elif [ -x "$r" ] ; then
86                 echo "%%attr(755,root,root) $2" >> $1.files
87         elif [ -f "$r" ]; then
88                 echo "$2" >> $1.files
89         else
90                 echo "Error generation $1 files list!"
91                 echo "$r: no such file or directory!"
92                 return 1
93         fi
94 }
95
96 echo "%defattr(644,root,root,755)" > examples.files
97 ifecho examples %{_examplesdir}/qt5
98 for f in `find $RPM_BUILD_ROOT%{_examplesdir}/qt5 -printf "%%P "`; do
99         ifecho examples %{_examplesdir}/qt5/$f
100 done
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post           -p /sbin/ldconfig
106 %postun         -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %ghost %{_libdir}/libQt5Declarative.so.?
111 %attr(755,root,root) %{_libdir}/libQt5Declarative.so.*.*
112 %attr(755,root,root) %{_qtdir}/bin/*
113 %attr(755,root,root) %{_qtdir}/imports
114 %attr(755,root,root) %{_qtdir}/plugins
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libQt5Declarative.so
119 %{_libdir}/libQt5Declarative.la
120 %{_libdir}/libQt5Declarative.prl
121 %{_libdir}/cmake/Qt5Declarative
122 %{_includedir}/qt5/QtDeclarative
123 %{_pkgconfigdir}/*.pc
124 %{_qtdir}/mkspecs
125
126 %files examples -f examples.files
This page took 0.07603 seconds and 3 git commands to generate.