]> git.pld-linux.org Git - packages/qt5-qtnetworkauth.git/blob - qt5-qtnetworkauth.spec
- unconditional noarch subpackages
[packages/qt5-qtnetworkauth.git] / qt5-qtnetworkauth.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # disable features to able to build without installed qt5
4 %bcond_without  doc             # documentation
5
6 %if %{with bootstrap}
7 %undefine       with_doc
8 %endif
9
10 %define         orgname         qtnetworkauth
11 %define         qtbase_ver              %{version}
12 %define         qtdeclarative_ver       %{version}
13 %define         qttools_ver             5.9
14 Summary:        The Qt5 Network Auth library
15 Summary(pl.UTF-8):      Biblioteka Qt5 Network Auth
16 Name:           qt5-%{orgname}
17 Version:        5.12.3
18 Release:        2
19 License:        GPL v3 or commercial
20 Group:          X11/Libraries
21 Source0:        http://download.qt.io/official_releases/qt/5.12/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
22 # Source0-md5:  bc8f9a2e8e30476ba613c020f811c95c
23 URL:            https://www.qt.io/
24 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
25 BuildRequires:  Qt5Network-devel >= %{qtbase_ver}
26 %if %{with doc}
27 BuildRequires:  qt5-assistant >= %{qttools_ver}
28 %endif
29 BuildRequires:  qt5-build >= %{qtbase_ver}
30 BuildRequires:  qt5-qmake >= %{qtbase_ver}
31 BuildRequires:  rpmbuild(macros) >= 1.752
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         specflags       -fno-strict-aliasing
37 %define         qt5dir          %{_libdir}/qt5
38
39 %description
40 Qt is a cross-platform application and UI framework. Using Qt, you can
41 write web-enabled applications once and deploy them across desktop,
42 mobile and embedded systems without rewriting the source code.
43
44 This package contains Qt5 Network Auth library.
45
46 %description -l pl.UTF-8
47 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
48 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
49 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
50 źródłowego.
51
52 Ten pakiet zawiera bibliotekę Qt5 Network Auth.
53
54 %package -n Qt5NetworkAuth
55 Summary:        The Qt5 Network Auth library
56 Summary(pl.UTF-8):      Biblioteka Qt5 Network Auth
57 Group:          Libraries
58 Requires:       Qt5Core >= %{qtbase_ver}
59 Requires:       Qt5Network >= %{qtbase_ver}
60
61 %description -n Qt5NetworkAuth
62 Qt5 Network Auth library provides classes for network authentication.
63
64 %description -n Qt5NetworkAuth -l pl.UTF-8
65 Biblioteka Qt5 Network Auth dostarcza klasy do uwierzytelniania w
66 sieci.
67
68 %package -n Qt5NetworkAuth-devel
69 Summary:        Qt5 Network Auth library - development files
70 Summary(pl.UTF-8):      Biblioteka Qt5 Network Auth - pliki programistyczne
71 Group:          Development/Libraries
72 Requires:       Qt5Core-devel >= %{qtbase_ver}
73 Requires:       Qt5Network-devel >= %{qtbase_ver}
74 Requires:       Qt5NetworkAuth = %{version}-%{release}
75
76 %description -n Qt5NetworkAuth-devel
77 Qt5 Network Auth library - development files.
78
79 %description -n Qt5NetworkAuth-devel -l pl.UTF-8
80 Biblioteka Qt5 NetworkAuth - pliki programistyczne.
81
82 %package doc
83 Summary:        Qt5 Network Auth documentation in HTML format
84 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Network Auth w formacie HTML
85 License:        FDL v1.3
86 Group:          Documentation
87 Requires:       qt5-doc-common >= %{qtbase_ver}
88 BuildArch:      noarch
89
90 %description doc
91 Qt5 Network Auth documentation in HTML format.
92
93 %description doc -l pl.UTF-8
94 Dokumentacja do biblioteki Qt5 Netwok Auth w formacie HTML.
95
96 %package doc-qch
97 Summary:        Qt5 Network Auth documentation in QCH format
98 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Network Auth w formacie QCH
99 License:        FDL v1.3
100 Group:          Documentation
101 Requires:       qt5-doc-common >= %{qtbase_ver}
102 BuildArch:      noarch
103
104 %description doc-qch
105 Qt5 Network Auth documentation in QCH format.
106
107 %description doc-qch -l pl.UTF-8
108 Dokumentacja do biblioteki Qt5 Network Auth w formacie QCH.
109
110 %package examples
111 Summary:        Qt5 Network Auth examples
112 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Network Auth
113 License:        BSD or commercial
114 Group:          X11/Development/Libraries
115 BuildArch:      noarch
116
117 %description examples
118 Qt5 Network Auth examples.
119
120 %description examples -l pl.UTF-8
121 Przykłady do biblioteki Qt5 Network Auth.
122
123 %prep
124 %setup -q -n %{orgname}-everywhere-src-%{version}
125
126 %build
127 qmake-qt5
128 %{__make}
129 %{?with_doc:%{__make} docs}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         INSTALL_ROOT=$RPM_BUILD_ROOT
136
137 %if %{with doc}
138 %{__make} install_docs \
139         INSTALL_ROOT=$RPM_BUILD_ROOT
140 %endif
141
142 # useless symlinks
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
144 # actually drop *.la, follow policy of not packaging them when *.pc exist
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
146
147 # Prepare some files list
148 ifecho() {
149         r="$RPM_BUILD_ROOT$2"
150         if [ -d "$r" ]; then
151                 echo "%%dir $2" >> $1.files
152         elif [ -x "$r" ] ; then
153                 echo "%%attr(755,root,root) $2" >> $1.files
154         elif [ -f "$r" ]; then
155                 echo "$2" >> $1.files
156         else
157                 echo "Error generation $1 files list!"
158                 echo "$r: no such file or directory!"
159                 return 1
160         fi
161 }
162 ifecho_tree() {
163         ifecho $1 $2
164         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
165                 ifecho $1 $2/$f
166         done
167 }
168
169 echo "%defattr(644,root,root,755)" > examples.files
170 ifecho_tree examples %{_examplesdir}/qt5/oauth
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -n Qt5NetworkAuth -p /sbin/ldconfig
176 %postun -n Qt5NetworkAuth -p /sbin/ldconfig
177
178 %files -n Qt5NetworkAuth
179 %defattr(644,root,root,755)
180 %doc LICENSE.GPL3-EXCEPT dist/changes-*
181 %attr(755,root,root) %{_libdir}/libQt5NetworkAuth.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libQt5NetworkAuth.so.5
183
184 %files -n Qt5NetworkAuth-devel
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libQt5NetworkAuth.so
187 %{_libdir}/libQt5NetworkAuth.prl
188 %{_includedir}/qt5/QtNetworkAuth
189 %{_libdir}/cmake/Qt5NetworkAuth
190 %{_pkgconfigdir}/Qt5NetworkAuth.pc
191 %{_libdir}/qt5/mkspecs/modules/qt_lib_networkauth.pri
192 %{_libdir}/qt5/mkspecs/modules/qt_lib_networkauth_private.pri
193
194 %if %{with doc}
195 %files doc
196 %defattr(644,root,root,755)
197 %{_docdir}/qt5-doc/qtnetworkauth
198
199 %files doc-qch
200 %defattr(644,root,root,755)
201 %{_docdir}/qt5-doc/qtnetworkauth.qch
202 %endif
203
204 %files examples -f examples.files
205 %defattr(644,root,root,755)
206 # XXX: dir shared with qt5-qtbase-examples
207 %dir %{_examplesdir}/qt5
This page took 0.108847 seconds and 3 git commands to generate.