]> git.pld-linux.org Git - packages/qt4-plugin-qca-ossl.git/blob - qt4-plugin-qca-ossl.spec
- rel 4
[packages/qt4-plugin-qca-ossl.git] / qt4-plugin-qca-ossl.spec
1 %define         rname qca-ossl
2 #
3 %define snap    beta3
4 Summary:        Qt Cryptographic Architecture (QCA) SSL/TLS plugin
5 Summary(pl.UTF-8):      Wtyczka SSL/TLS dla Qt Cryptographic Architecture (QCA)
6 Name:           qt4-plugin-%{rname}
7 Version:        2.0.0
8 Release:        0.%{snap}.4
9 Epoch:          1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        http://delta.affinix.com/download/qca/2.0/plugins/qca-ossl-%{version}-%{snap}.tar.bz2
13 # Source0-md5:  bdc62c01321385c7da8d27b3902910ce
14 URL:            http://delta.affinix.com/qca/
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  openssl-devel >= 0.9.7d
17 BuildRequires:  qca-devel >= 2.0.0
18 BuildRequires:  qt4-build
19 BuildRequires:  qt4-qmake >= 4.3.3-3
20 BuildRequires:  which
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _plugindir %{_libdir}/qt4/plugins/crypto
24
25 # chrpath stripping fails
26 %define         no_install_post_chrpath 1
27
28 %description
29 A plugin to provide SSL/TLS capability to programs that utilize the Qt
30 Cryptographic Architecture (QCA).
31
32 %description -l pl.UTF-8
33 Wtyczka pozwalająca wykorzystać możliwości SSL/TLS w programach
34 korzystających z Qt Cryptographic Architecture (QCA).
35
36 %prep
37 %setup -qn %{rname}-%{version}-%{snap}
38
39 %build
40 export QTDIR=%{_libdir}/qt4
41 ./configure
42
43 qmake-qt4 %{rname}.pro \
44         QMAKE_CXX="%{__cxx}" \
45         QMAKE_LINK="%{__cxx}" \
46         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
47         QMAKE_RPATH=
48
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         INSTALL_ROOT=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README
63 %attr(755,root,root) %{_plugindir}/*.so
This page took 0.181668 seconds and 3 git commands to generate.