]> git.pld-linux.org Git - packages/qt-plugin-qca-tls.git/blob - qt-plugin-qca-tls.spec
- BR += qmake.
[packages/qt-plugin-qca-tls.git] / qt-plugin-qca-tls.spec
1 %define         rname qca-tls
2 #
3 Summary:        Qt Cryptographic Architecture (QCA) SSL/TLS plugin
4 Summary(pl):    Wtyczka SSL/TLS dla Qt Cryptographic Architecture (QCA)
5 Name:           qt-plugin-%{rname}
6 Version:        1.0
7 Release:        3
8 Epoch:          1
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        http://delta.affinix.com/qca/%{rname}-1.0.tar.bz2
12 # Source0-md5:  886b1f60fc31de3b1a0bd93281e27b73
13 URL:            http://delta.affinix.com/qca/
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  qmake
17 BuildRequires:  qt-devel >= 3.1.2
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _plugindir %{_libdir}/qt/plugins-mt/crypto
21
22 %description
23 A plugin to provide SSL/TLS capability to programs that utilize the Qt
24 Cryptographic Architecture (QCA).
25
26 %description -l pl
27 Wtyczka pozwalaj±ca wykorzystaæ mo¿liwo¶ci SSL/TLS w programach
28 korzystaj±cych z Qt Cryptographic Architecture (QCA).
29
30 %prep
31 %setup -qn %{rname}-%{version}
32
33 %build
34 export QTDIR=%{_prefix}
35 ./configure
36
37 qmake %{rname}.pro \
38         QMAKE_CXX="%{__cxx}" \
39         QMAKE_LINK="%{__cxx}" \
40         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
41         QMAKE_RPATH=
42
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         INSTALL_ROOT=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README
57 %attr(755,root,root) %{_plugindir}/*.so
This page took 0.062852 seconds and 4 git commands to generate.