]> git.pld-linux.org Git - packages/qt-gstreamer.git/blob - qt-gstreamer.spec
- added Qt5Declarative plugin
[packages/qt-gstreamer.git] / qt-gstreamer.spec
1 # NOTE: copy package to qt-gstreamer0.10 before updating to 1.0.x (when available)
2 #
3 # Conditional build:
4 %bcond_without  qt4     # Qt 4 libraries
5 %bcond_without  qt5     # Qt 5 libraries
6 #
7 Summary:        QtGStreamer - libraries integrating Qt 4 with GStreamer
8 Summary(pl.UTF-8):      QtGStreamer - biblioteki integrujące Qt 4 z GStreamerem
9 Name:           qt-gstreamer
10 Version:        0.10.3
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://gstreamer.freedesktop.org/src/qt-gstreamer/%{name}-%{version}.tar.bz2
15 # Source0-md5:  1dfbca4ffa924b0896dadb42221600e2
16 URL:            http://gstreamer.net/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  bison
19 BuildRequires:  boost-devel >= 1.39
20 BuildRequires:  cmake >= 2.8.9
21 BuildRequires:  flex
22 BuildRequires:  glib2-devel >= 2.0
23 BuildRequires:  gstreamer0.10-devel >= 0.10.33
24 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10.33
25 BuildRequires:  libstdc++-devel >= 6:4.5
26 BuildRequires:  pkgconfig
27 %if %{with qt4}
28 BuildRequires:  QtCore-devel >= 4.7
29 BuildRequires:  QtDeclarative-devel >= 4.7
30 BuildRequires:  QtGui-devel >= 4.7
31 BuildRequires:  QtOpenGL-devel >= 4.7
32 BuildRequires:  QtTest-devel >= 4.7
33 BuildRequires:  qt4-qmake >= 4.7
34 %endif
35 %if %{with qt5}
36 BuildRequires:  Qt5Core-devel >= 5.0.0
37 BuildRequires:  Qt5Declarative-devel >= 5.0.0
38 BuildRequires:  Qt5Gui-devel >= 5.0.0
39 BuildRequires:  Qt5OpenGL-devel >= 5.0.0
40 BuildRequires:  Qt5Widgets-devel >= 5.0.0
41 BuildRequires:  Qt5Test-devel >= 5.0.0
42 BuildRequires:  qt5-qmake >= 5.0.0
43 %endif
44 Requires:       QtCore >= 4.7
45 Requires:       QtGui >= 4.7
46 Requires:       QtOpenGL >= 4.7
47 Requires:       gstreamer0.10 >= 0.10.33
48 Requires:       gstreamer0.10-plugins-base >= 0.10.33
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 QtGStreamer is a set of libraries and plugins providing C++ bindings
53 for GStreamer with a Qt-style API plus some helper classes for
54 integrating GStreamer better in Qt 4 applications.
55
56 Currently, it consists of the following parts:
57  * QtGLib - library providing C++/Qt 4 bindings for parts of the GLib
58    and GObject APIs, a base on which QtGStreamer is built.
59  * QtGStreamer - library providing C++/Qt 4 bindings for GStreamer
60  * QtGStreamerUi - library providing integration with QtGui;
61    currently, it only provides a video widget that embeds GStreamer's
62    video sinks.
63  * QtGStreamerUtils - library providing some high level utility
64    classes.
65
66 In addition, it provides a "qwidgetvideosink" GStreamer element, an
67 video sink element that can draw directly on QWidgets using QPainter.
68
69 %description -l pl.UTF-8
70 QtGStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
71 GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
72 integracji GStreamera w aplikacjach Qt 4.
73
74 Obecnie zawiera następujące części:
75  - QtGLib - biblioteka z wiązaniami C++/Qt 4 dla części API bibliotek
76    GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
77  - QtGStreamer - biblioteka z wiązaniami C++/Qt 4 do GStreamera
78  - QtGStreamerUi - biblioteka integrująca z QtGui; obecnie zawiera
79    tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
80  - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
81    wysokiego poziomu.
82
83 Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
84 element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
85 użyciu QPaintera.
86
87 %package devel
88 Summary:        Header files for QtGStreamer libraries
89 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek QtGStreamer
90 Group:          Development/Libraries
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       QtCore-devel >= 4.7
93 Requires:       QtGui-devel >= 4.7
94 Requires:       gstreamer0.10-devel >= 0.10.33
95 Requires:       gstreamer0.10-plugins-base-devel >= 0.10.33
96
97 %description devel
98 Header files for QtGStreamer libraries.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe bibliotek QtGStreamer.
102
103 %package -n QtDeclarative-plugin-gstreamer
104 Summary:        Qt GStreamer plugin for QtDeclarative
105 Summary(pl.UTF-8):      Wtyczka Qt GStreamer dla QtDeclarative
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       QtDeclarative >= 4.7
109
110 %description -n QtDeclarative-plugin-gstreamer
111 Qt GStreamer plugin for QtDeclarative.
112
113 %description -n QtDeclarative-plugin-gstreamer -l pl.UTF-8
114 Wtyczka Qt GStreamer dla QtDeclarative.
115
116 %package -n qt5-gstreamer
117 Summary:        Qt5GStreamer - libraries integrating Qt 5 with GStreamer
118 Summary(pl.UTF-8):      Qt5GStreamer - biblioteki integrujące Qt 5 z GStreamerem
119 Group:          Libraries
120 Requires:       Qt5Core >= 5.0.0
121 Requires:       Qt5Gui >= 5.0.0
122 Requires:       Qt5OpenGL >= 5.0.0
123 Requires:       gstreamer0.10 >= 0.10.33
124 Requires:       gstreamer0.10-plugins-base >= 0.10.33
125
126 %description -n qt5-gstreamer
127 Qt5GStreamer is a set of libraries and plugins providing C++ bindings
128 for GStreamer with a Qt-style API plus some helper classes for
129 integrating GStreamer better in Qt 5 applications.
130
131 Currently, it consists of the following parts:
132  * Qt5GLib - library providing C++/Qt 5 bindings for parts of the GLib
133    and GObject APIs, a base on which Qt5GStreamer is built.
134  * Qt5GStreamer - library providing C++/Qt 5 bindings for GStreamer
135  * Qt5GStreamerUi - library providing integration with Qt5Gui;
136    currently, it only provides a video widget that embeds GStreamer's
137    video sinks.
138  * Qt5GStreamerUtils - library providing some high level utility
139    classes.
140
141 In addition, it provides a "qwidgetvideosink" GStreamer element, an
142 video sink element that can draw directly on QWidgets using QPainter.
143
144 %description -n qt5-gstreamer -l pl.UTF-8
145 Qt5GStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
146 GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
147 integracji GStreamera w aplikacjach Qt 5.
148
149 Obecnie zawiera następujące części:
150  - Qt5GLib - biblioteka z wiązaniami C++/Qt 5 dla części API bibliotek
151    GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
152  - Qt5GStreamer - biblioteka z wiązaniami C++/Qt 5 do GStreamera
153  - Qt5GStreamerUi - biblioteka integrująca z Qt5Gui; obecnie zawiera
154    tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
155  - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
156    wysokiego poziomu.
157
158 Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
159 element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
160 użyciu QPaintera.
161
162 %package -n qt5-gstreamer-devel
163 Summary:        Header files for Qt5GStreamer libraries
164 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek QtGStreamer
165 Group:          Development/Libraries
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       Qt5Core-devel >= 5.0.0
168 Requires:       Qt5Gui-devel >= 5.0.0
169 Requires:       gstreamer0.10-devel >= 0.10.33
170 Requires:       gstreamer0.10-plugins-base-devel >= 0.10.33
171
172 %description -n qt5-gstreamer-devel
173 Header files for Qt5GStreamer libraries.
174
175 %description -n qt5-gstreamer-devel -l pl.UTF-8
176 Pliki nagłówkowe bibliotek Qt5GStreamer.
177
178 %package -n Qt5Declarative-plugin-gstreamer
179 Summary:        Qt GStreamer plugin for Qt5Declarative
180 Summary(pl.UTF-8):      Wtyczka Qt GStreamer dla Qt5Declarative
181 Group:          Libraries
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       Qt5Declarative >= 5.0.0
184
185 %description -n Qt5Declarative-plugin-gstreamer
186 Qt GStreamer plugin for Qt5Declarative.
187
188 %description -n Qt5Declarative-plugin-gstreamer -l pl.UTF-8
189 Wtyczka Qt GStreamer dla Qt5Declarative.
190
191 %prep
192 %setup -q
193
194 %build
195 %if %{with qt4}
196 install -d build-qt4
197 cd build-qt4
198 %cmake .. \
199         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
200         -DQTGSTREAMER_EXAMPLES=OFF \
201         -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
202 %{__make}
203 cd ..
204 %endif
205
206 %if %{with qt5}
207 install -d build-qt5
208 cd build-qt5
209 %cmake .. \
210         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
211         -DQTGSTREAMER_EXAMPLES=OFF \
212         -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt5 \
213         -DQT_VERSION=5
214 %{__make}
215 cd ..
216 %endif
217
218 %install
219 rm -rf $RPM_BUILD_ROOT
220
221 %if %{with qt4}
222 %{__make} -C build-qt4 install \
223         DESTDIR=$RPM_BUILD_ROOT
224 %endif
225
226 %if %{with qt5}
227 %{__make} -C build-qt5 install \
228         DESTDIR=$RPM_BUILD_ROOT
229 %endif
230
231 %clean
232 rm -rf $RPM_BUILD_ROOT
233
234 %post   -p /sbin/ldconfig
235 %postun -p /sbin/ldconfig
236
237 %post   -n qt5-gstreamer -p /sbin/ldconfig
238 %postun -n qt5-gstreamer -p /sbin/ldconfig
239
240 %if %{with qt4}
241 %files
242 %defattr(644,root,root,755)
243 %doc NEWS README
244 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so.*.*.*
245 %attr(755,root,root) %ghost %{_libdir}/libQtGLib-2.0.so.0
246 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so.*.*.*
247 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamer-0.10.so.0
248 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so.*.*.*
249 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUi-0.10.so.0
250 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so.*.*.*
251 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUtils-0.10.so.0
252 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqtvideosink.so
253
254 %files devel
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so
257 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so
258 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so
259 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so
260 %{_includedir}/QtGStreamer
261 %{_pkgconfigdir}/QtGLib-2.0.pc
262 %{_pkgconfigdir}/QtGStreamer-0.10.pc
263 %{_pkgconfigdir}/QtGStreamerUi-0.10.pc
264 %{_pkgconfigdir}/QtGStreamerUtils-0.10.pc
265 %{_libdir}/cmake/QtGStreamer
266
267 %files -n QtDeclarative-plugin-gstreamer
268 %defattr(644,root,root,755)
269 %dir %{_libdir}/qt4/imports/QtGStreamer
270 %attr(755,root,root) %{_libdir}/qt4/imports/QtGStreamer/libQtGStreamerQuick1.so
271 %{_libdir}/qt4/imports/QtGStreamer/qmldir
272 %endif
273
274 %if %{with qt5}
275 %files -n qt5-gstreamer
276 %defattr(644,root,root,755)
277 %doc NEWS README
278 %attr(755,root,root) %{_libdir}/libQt5GLib-2.0.so.*.*.*
279 %attr(755,root,root) %ghost %{_libdir}/libQt5GLib-2.0.so.0
280 %attr(755,root,root) %{_libdir}/libQt5GStreamer-0.10.so.*.*.*
281 %attr(755,root,root) %ghost %{_libdir}/libQt5GStreamer-0.10.so.0
282 %attr(755,root,root) %{_libdir}/libQt5GStreamerUi-0.10.so.*.*.*
283 %attr(755,root,root) %ghost %{_libdir}/libQt5GStreamerUi-0.10.so.0
284 %attr(755,root,root) %{_libdir}/libQt5GStreamerUtils-0.10.so.*.*.*
285 %attr(755,root,root) %ghost %{_libdir}/libQt5GStreamerUtils-0.10.so.0
286 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqt5videosink.so
287
288 %files -n qt5-gstreamer-devel
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_libdir}/libQt5GLib-2.0.so
291 %attr(755,root,root) %{_libdir}/libQt5GStreamer-0.10.so
292 %attr(755,root,root) %{_libdir}/libQt5GStreamerUi-0.10.so
293 %attr(755,root,root) %{_libdir}/libQt5GStreamerUtils-0.10.so
294 %{_includedir}/Qt5GStreamer
295 %{_pkgconfigdir}/Qt5GLib-2.0.pc
296 %{_pkgconfigdir}/Qt5GStreamer-0.10.pc
297 %{_pkgconfigdir}/Qt5GStreamerUi-0.10.pc
298 %{_pkgconfigdir}/Qt5GStreamerUtils-0.10.pc
299 %{_libdir}/cmake/Qt5GStreamer
300
301 %files -n Qt5Declarative-plugin-gstreamer
302 %defattr(644,root,root,755)
303 %dir %{_libdir}/qt5/imports/QtGStreamer
304 %attr(755,root,root) %{_libdir}/qt5/imports/QtGStreamer/libQtGStreamerQuick1.so
305 %{_libdir}/qt5/imports/QtGStreamer/qmldir
306 %endif
This page took 0.195179 seconds and 3 git commands to generate.