]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- initital version, from mdk. NFY
[packages/qemu.git] / qemu.spec
1 Summary:        QEMU CPU Emulator
2 Name:           qemu
3 Version:        0.5.2
4 Release:        0.1
5 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
6 #Patch0:                qemu-0.5.0-cvsupdates.patch.bz2
7 #Patch1:                qemu-0.1.6-glibc23-ldscripts.patch.bz2
8 #Patch2:                qemu-0.5.0-sdl-static-libs.patch.bz2
9 #Patch3:                qemu-0.5.0-DESTDIR.patch.bz2
10 #Patch4:                qemu-0.5.0-lib64.patch.bz2
11 #Patch5:                qemu-0.5.0-amd64.patch.bz2
12 #Patch6:                qemu-0.5.0-vl-amd64.patch.bz2
13 License:        GPL
14 URL:            http://fabrice.bellard.free.fr/qemu/
15 Group:          Applications/Emulators
16 BuildRequires:  SDL-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 QEMU is a FAST! processor emulator. By using dynamic translation it
21 achieves a reasonnable speed while being easy to port on new host
22 CPUs. QEMU has two operating modes:
23
24 - User mode emulation. In this mode, QEMU can launch Linux processes
25   compiled for one CPU on another CPU. Linux system calls are converted
26   because of endianness and 32/64 bit mismatches. Wine (Windows
27   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
28
29 - Full system emulation. In this mode, QEMU emulates a full system,
30   including a processor and various peripherials. Currently, it is only
31   used to launch an x86 Linux kernel on an x86 Linux system. It enables
32   easier testing and debugging of system code. It can also be used to
33   provide virtual hosting of several virtual PC on a single server.
34
35 %prep
36 %setup -q
37 #%patch0 -p1 -b .cvsupdates
38 #%patch1 -p1 -b .glibc23-ldscripts
39 #%patch2 -p1 -b .sdl-static-libs
40 #%patch3 -p1 -b .DESTDIR
41 #%patch4 -p1 -b .lib64
42 #%patch5 -p1 -b .amd64
43 # needs to 64-bit clean softmmu code or MAP_32BIT physical_ram_base
44 # but other problems remain.
45 #%patch6 -p1 -b .vl-amd64
46
47 %build
48 ./configure --prefix=%{_prefix}
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README qemu-doc.html
62 %ifarch %{ix86}
63 %attr(755,root,root) %{_bindir}/qemu-fast
64 %endif
65 %ifarch %{ix86} ppc
66 %{_bindir}/qemu
67 %endif
68 %{_bindir}/qemu-mkcow
69 %{_bindir}/qemu-arm
70 %{_bindir}/qemu-i386
71 %{_bindir}/qemu-sparc
72 %{_mandir}/man1/qemu.1*
73 %dir %{_datadir}/qemu
74 %{_datadir}/qemu/bios.bin
75 %{_datadir}/qemu/vgabios.bin
This page took 0.031377 seconds and 4 git commands to generate.