]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
3342a1b241b9cd59c52252e8f83711cad59302b2
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 #
5 # Conditional build:
6 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
7 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
8 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
9 # Note that gcc4 build is very problematic and not supported by qemu team
10 %bcond_with     gcc4                    # use gcc4 patches (broke build on gcc33)
11 %bcond_without  dist_kernel             # without distribution kernel
12 %bcond_without  kernel                  # build kqemu KERNEL MODULES
13 %bcond_without  up                      # don't build up module
14 %bcond_without  smp                     # don't build SMP module
15 %bcond_without  userspace               # don't build userspace utilities
16 #
17
18 %define _kqemu_version  1.3.0pre11
19 %define         _rel    1
20 Summary:        QEMU CPU Emulator
21 Summary(pl.UTF-8):      QEMU - emulator procesora
22 Name:           qemu
23 Version:        0.9.0
24 Release:        %{_rel}%{?with_kqemu:k}
25 License:        GPL
26 Group:          Applications/Emulators
27 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
28 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
29 # Source0-md5:  ab11a03ba30cf4a70641f0f170473d69
30 Source1:        http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
31 # Source1-md5:  970521874ef8b1ba4598925ace5936c3
32 Patch0:         %{name}-nostatic.patch
33 Patch1:         %{name}-cc.patch
34 Patch3:         %{name}-dot.patch
35 Patch4:         %{name}-gcc4_x86.patch
36 Patch5:         %{name}-gcc4_ppc.patch
37 Patch6:         %{name}-nosdlgui.patch
38 Patch7:         %{name}-ifup.patch
39 # Proof of concept, for reference, do not remove
40 Patch8:         %{name}-kde_virtual_workspaces_hack.patch
41 # http://gwenole.beauchesne.info/en/projects/qemu
42 Patch9:         %{name}-0.8.0-gcc4-hacks.patch
43 Patch11:        %{name}-0.7.2-gcc4-opts.patch
44 #Patch12:       %{name}-0.7.2-dyngen-check-stack-clobbers.patch
45 URL:            http://fabrice.bellard.free.fr/qemu/
46 %if %{with kernel} && %{with dist_kernel}
47 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
48 BuildRequires:  rpmbuild(macros) >= 1.330
49 %endif
50 %if %{with userspace}
51 BuildRequires:  SDL-devel >= 1.2.1
52 BuildRequires:  alsa-lib-devel
53 %{!?with_gcc4:BuildRequires:    gcc < 5:4.0}
54 BuildRequires:  perl-tools-pod
55 BuildRequires:  tetex
56 BuildRequires:  sed >= 4.0
57 %endif
58 Requires:       SDL >= 1.2.1
59 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
60 ExclusiveArch:  %{ix86} %{x8664} %{!?with_kqemu:ppc}
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 # some SPARC boot image in ELF format
64 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
65
66 %description
67 QEMU is a FAST! processor emulator. By using dynamic translation it
68 achieves a reasonnable speed while being easy to port on new host
69 CPUs. QEMU has two operating modes:
70
71 - User mode emulation. In this mode, QEMU can launch Linux processes
72   compiled for one CPU on another CPU. Linux system calls are converted
73   because of endianness and 32/64 bit mismatches. Wine (Windows
74   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
75
76 - Full system emulation. In this mode, QEMU emulates a full system,
77   including a processor and various peripherials. It can also be used to
78   provide virtual hosting of several virtual PC on a single server.
79
80 %description -l pl.UTF-8
81 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
82 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
83 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
84
85 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
86   procesy linuksowe skompilowane dla jednego procesora na innym
87   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
88   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
89   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
90   cele QEMU.
91
92 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
93   włączając w to procesor i różne urządzenia peryferyjne. Może być także
94   używane do wirtualnego hostowania kilku wirtualnych pecetów na
95   pojedynczym serwerze.
96
97 %package -n kernel%{_alt_kernel}-misc-kqemu
98 Summary:        kqemu - kernel module
99 Summary(pl.UTF-8):      kqemu - moduł jądra
100 Version:        %{_kqemu_version}
101 Release:        %{_rel}@%{_kernel_ver_str}
102 Group:          Base/Kernel
103 %{?with_dist_kernel:%requires_releq_kernel_up}
104 License:        GPL v2
105 Requires(post,postun):  /sbin/depmod
106 Requires:       module-init-tools >= 3.2.2-2
107
108 %description -n kernel%{_alt_kernel}-misc-kqemu
109 kqemu - kernel module.
110
111 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
112 kqemu - moduł jądra.
113
114 %package -n kernel%{_alt_kernel}-smp-misc-kqemu
115 Summary:        kqemu - SMP kernel module
116 Summary(pl.UTF-8):      kqemu - moduł jądra SMP
117 Version:        %{_kqemu_version}
118 Release:        %{_rel}@%{_kernel_ver_str}
119 Group:          Base/Kernel
120 %{?with_dist_kernel:%requires_releq_kernel_smp}
121 License:        GPL v2
122 Requires(post,postun):  /sbin/depmod
123 Requires:       module-init-tools >= 3.2.2-2
124
125 %description -n kernel%{_alt_kernel}-smp-misc-kqemu
126 kqemu - SMP kernel module.
127
128 %description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl.UTF-8
129 kqemu - moduł jądra SMP.
130
131 %prep
132 %if %{with kernel}
133 %if %{with dist_kernel} && %{without up} && %{without smp}
134 %{error:%{name}: If building kernel module You need to enable at least one of up or smp}
135 exit 1
136 %endif
137 %endif
138
139 %setup -q %{?with_kernel:-a1}
140 %patch0 -p1
141 %patch1 -p1
142 %patch3 -p1
143 %if %{with gcc4}
144 %patch9 -p1
145 %patch11 -p1
146 #%patch12 -p1
147 #%patch4 -p0
148 %patch5 -p1
149 %endif
150 %{?with_nosdlgui:%patch6 -p1}
151 %patch7 -p1
152 #%patch8 -p1
153
154 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
155 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
156
157 # cannot use optflags on x86 - they cause "no register to spill" errors
158 %if %{with cflags_passing}
159 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
160 %else
161 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
162 %endif
163
164 %if %{with kernel}
165 echo -n > kqemu-%{_kqemu_version}/install.sh
166
167 cat <<'EOF' > modprobe.conf
168 # enable dynamic major
169 options kqemu major=0
170 # for autoloading from static dev
171 #alias char-major-250 kqemu
172 EOF
173
174 cat <<'EOF' > udev.conf
175 KERNEL=="kqemu", NAME="%k", MODE="0666"
176 EOF
177 %endif
178
179 %build
180 %if %{with kernel}
181 cd kqemu-%{_kqemu_version}
182
183 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
184 %ifarch %{x8664}
185 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
186 %{__make} -C common
187 mv -f kqemu-mod-x86_64.o{,.bin}
188 %else
189 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
190 %{__make} -C common
191 mv -f kqemu-mod-i386.o{,.bin}
192 %endif
193
194 mv -f kqemu-linux.c{,.orig}
195 cat > Makefile <<'EOF'
196 obj-m := kqemu.o
197 kqemu-objs:= kqemu-linux.o kqemu-mod.o
198
199 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
200         cp $< $@
201 EOF
202
203 %build_kernel_modules -m kqemu <<'EOF'
204 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
205         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
206                 kqemu-linux.c.orig > kqemu-linux.c
207 else
208         cat kqemu-linux.c.orig > kqemu-linux.c
209 fi
210 EOF
211 cd -
212 %endif
213
214 %if %{with userspace}
215 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
216 # they can be passed if the cflags_passing bcond is used
217 ./configure \
218         --prefix=%{_prefix} \
219         --cc="%{__cc}" \
220         --host-cc="%{__cc}" \
221         --make="%{__make}" \
222 %if %{with kqemu}
223         --kernel-path=%{_kernelsrcdir} \
224 %else
225         --disable-kqemu \
226 %endif
227         %{?with_gcc4:--disable-gcc-check} \
228         --enable-alsa \
229         --interp-prefix=%{_libdir}/%{name}
230 %{__make}
231 %endif
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235
236 %if %{with userspace}
237 %{__make} install \
238         DESTDIR=$RPM_BUILD_ROOT
239
240 install -d $RPM_BUILD_ROOT/sbin
241 cat <<'EOF' > $RPM_BUILD_ROOT/sbin/qemu-ifup
242 #!/bin/sh
243 if [ -f /etc/sysconfig/qemu ]; then
244         . /etc/sysconfig/qemu
245 fi
246 # of course this will work only for one interface. a lot possible to involve
247 sudo /sbin/ifconfig $1 ${INTERFACE_ADDR:-172.20.0.1}
248 EOF
249 %endif
250
251 %if %{with kernel}
252 %install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
253 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
254 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
255 %if %{with smp} && %{with dist_kernel}
256 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
257 %endif
258 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
259 %endif
260
261 # already packaged
262 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
263
264 %clean
265 rm -rf $RPM_BUILD_ROOT
266
267 %if %{with kernel}
268 %post
269 %banner %{name} -e <<EOF
270 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
271 modprobe kqemu
272 EOF
273 %endif
274
275 %post   -n kernel%{_alt_kernel}-misc-kqemu
276 %depmod %{_kernel_ver}
277
278 %postun -n kernel%{_alt_kernel}-misc-kqemu
279 %depmod %{_kernel_ver}
280
281 %post   -n kernel%{_alt_kernel}-smp-misc-kqemu
282 %depmod %{_kernel_ver}smp
283
284 %postun -n kernel%{_alt_kernel}-smp-misc-kqemu
285 %depmod %{_kernel_ver}smp
286
287 %if %{with userspace}
288 %files
289 %defattr(644,root,root,755)
290 %doc README qemu-doc.html qemu-tech.html
291 %attr(755,root,root) /sbin/qemu-ifup
292 %attr(755,root,root) %{_bindir}/*
293 %{_datadir}/qemu
294 %{_mandir}/man1/qemu.1*
295 %{_mandir}/man1/qemu-img.1*
296 %endif
297
298 %if %{with kernel}
299 %files -n kernel%{_alt_kernel}-misc-kqemu
300 %defattr(644,root,root,755)
301 %doc kqemu-%{_kqemu_version}/LICENSE
302 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
303 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
304 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
305
306 %if %{with smp} && %{with dist_kernel}
307 %files -n kernel%{_alt_kernel}-smp-misc-kqemu
308 %defattr(644,root,root,755)
309 %doc kqemu-%{_kqemu_version}/LICENSE
310 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
311 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
312 /lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
313 %endif
314 %endif
This page took 0.0453 seconds and 3 git commands to generate.