]> git.pld-linux.org Git - packages/qcommandline.git/blob - qcommandline.spec
pldize
[packages/qcommandline.git] / qcommandline.spec
1 Summary:        Command line parser for Qt programs
2 Name:           qcommandline
3 Version:        0.3.0
4 Release:        1
5 License:        LGPL v2+
6 Group:          X11/Libraries
7 Source0:        http://xf.iksaif.net/dev/qcommandline/%{name}-%{version}.tar.bz2
8 # Source0-md5:  89cb472a54306c7399c55285e142a84c
9 # http://dev.iksaif.net/issues/253
10 Patch0:         %{name}-fix-pkg-config-paths.patch
11 # http://dev.iksaif.net/issues/252 -- enhancements for PhantomJS
12 Patch101:       0001-new-ParameterFence-flag.patch
13 Patch102:       0002-new-NoShortName-flag-to-allow-options-with-no-short-.patch
14 Patch103:       0003-new-SuppressHelp-flag.patch
15 URL:            http://xf.iksaif.net/dev/qcommandline.html
16 BuildRequires:  QtCore-devel
17 BuildRequires:  cmake
18 BuildRequires:  qt4-build
19 BuildRequires:  qt4-qmake
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 QCommandLine is a command line parser for Qt programs (like getopt).
24
25 Features include options, switches, parameters and automatic
26 '--version' and '--help' generation.
27
28 %package devel
29 Summary:        Development files for %{name}
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 Development files for building against %{name}.
34
35 %prep
36 %setup -q
37 %patch0 -p1
38 %patch101 -p1
39 %patch102 -p1
40 %patch103 -p1
41
42 %build
43 install -d build
44 cd build
45 %cmake .. \
46         -DCMAKE_MODULES_INSTALL_DIR=%{_datadir}/cmake/Modules
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} -C build install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post   -p /sbin/ldconfig
61 %postun -p /sbin/ldconfig
62
63 %files
64 %defattr(644,root,root,755)
65 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*
66 %attr(755,root,root) %ghost %{_libdir}/lib%{name}.so.0
67
68 %files devel
69 %defattr(644,root,root,755)
70 %attr(755,root,root) %{_libdir}/lib%{name}.so
71 %{_includedir}/%{name}
72 %{_pkgconfigdir}/QCommandLine.pc
73 %{_datadir}/cmake/Modules/FindQCommandLine.cmake
74 %{_examplesdir}/%{name}-%{version}
This page took 0.063148 seconds and 3 git commands to generate.