]> git.pld-linux.org Git - packages/qcommandline.git/blob - qcommandline.spec
- more BR deps
[packages/qcommandline.git] / qcommandline.spec
1 Summary:        Command line parser for Qt programs
2 Name:           qcommandline
3 Version:        0.3.0
4 Release:        1
5 License:        LGPL v2+
6 Group:          X11/Libraries
7 URL:            http://xf.iksaif.net/dev/qcommandline.html
8 Source0:        http://xf.iksaif.net/dev/qcommandline/%{name}-%{version}.tar.bz2
9 # Source0-md5:  89cb472a54306c7399c55285e142a84c
10 # http://dev.iksaif.net/issues/253
11 Patch0:         %{name}-fix-pkg-config-paths.patch
12 # http://dev.iksaif.net/issues/252 -- enhancements for PhantomJS
13 Patch101:       0001-new-ParameterFence-flag.patch
14 Patch102:       0002-new-NoShortName-flag-to-allow-options-with-no-short-.patch
15 Patch103:       0003-new-SuppressHelp-flag.patch
16 BuildRequires:  QtCore-devel
17 BuildRequires:  cmake
18 BuildRequires:  qt4-build
19 BuildRequires:  qt4-qmake
20
21 %description
22 QCommandLine is a command line parser for Qt programs (like getopt).
23 Features include options, switches, parameters and automatic
24 - --version/--help generation.
25
26 %package devel
27 Summary:        Development files for %{name}
28 Requires:       %{name} = %{version}-%{release}
29 Requires:       cmake
30 Requires:       pkgconfig
31
32 %description devel
33 Development files for building against %{name}.
34
35 %prep
36 %setup -q
37 %patch0 -p1
38 %patch101 -p1
39 %patch102 -p1
40 %patch103 -p1
41
42 %build
43 mkdir build
44 cd build
45 %cmake .. \
46         -DCMAKE_MODULES_INSTALL_DIR=%{_datadir}/cmake/Modules
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} -C build install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*
58 %attr(755,root,root) %ghost %{_libdir}/lib%{name}.so.0
59
60 %files devel
61 %defattr(644,root,root,755)
62 %doc examples/
63 %attr(755,root,root) %{_libdir}/lib%{name}.so
64 %{_includedir}/%{name}
65 %{_pkgconfigdir}/QCommandLine.pc
66 %{_datadir}/cmake/Modules/FindQCommandLine.cmake
67
68 %post -p /sbin/ldconfig
69 %postun -p /sbin/ldconfig
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
This page took 0.067734 seconds and 3 git commands to generate.