]> git.pld-linux.org Git - packages/python3-zipp.git/blob - python3-zipp.spec
- python-zipp.spec updated to 3.7.0 for python 3.7+
[packages/python3-zipp.git] / python3-zipp.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 Summary:        pathlib-compatible Zipfile object wrapper
7 Summary(pl.UTF-8):      Obiektowe obudowanie Zipfile zgodne z pathlib
8 Name:           python3-zipp
9 Version:        3.7.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/zipp/
14 Source0:        https://files.pythonhosted.org/packages/source/z/zipp/zipp-%{version}.tar.gz
15 # Source0-md5:  5a1fc692b57b348d1e259484b405ddf6
16 URL:            https://pypi.org/project/zipp/
17 BuildRequires:  python3-modules >= 1:3.7
18 BuildRequires:  python3-setuptools >= 1:31.0.1
19 BuildRequires:  python3-setuptools_scm >= 3.4.1
20 BuildRequires:  python3-toml
21 %if %{with tests}
22 BuildRequires:  python3-func_timeout
23 BuildRequires:  python3-jaraco.itertools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 %if %{with doc}
28 BuildRequires:  python3-jaraco.packaging >= 8.2
29 BuildRequires:  python3-rst.linker >= 1.9
30 BuildRequires:  sphinx-pdg-3
31 %endif
32 Requires:       python3-modules >= 1:3.7
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 pathlib-compatible Zipfile object wrapper - backport from Python 3.8
38 zipfile module.
39
40 %description -l pl.UTF-8
41 Obiektowe obudowanie Zipfile zgodne z pathlib - backport z modułu
42 zipfile Pythona 3.8.
43
44 %package apidocs
45 Summary:        API documentation for Python zipp module
46 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona zipp
47 Group:          Documentation
48
49 %description apidocs
50 API documentation for Python zipp module.
51
52 %description apidocs -l pl.UTF-8
53 Dokumentacja API modułu Pythona zipp.
54
55 %prep
56 %setup -q -n zipp-%{version}
57
58 %build
59 %py3_build
60
61 %if %{with tests}
62 %{__python3} -m unittest test_zipp
63 %endif
64
65 %if %{with doc}
66 sphinx-build-3 -b html docs docs/_build/html
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %py3_install
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc CHANGES.rst LICENSE README.rst
80 %{py3_sitescriptdir}/zipp.py
81 %{py3_sitescriptdir}/__pycache__/zipp.cpython-*.py[co]
82 %{py3_sitescriptdir}/zipp-%{version}-py*.egg-info
83
84 %if %{with doc}
85 %files apidocs
86 %defattr(644,root,root,755)
87 %doc docs/_build/html/{_static,*.html,*.js}
88 %endif
This page took 0.062447 seconds and 3 git commands to generate.