]> git.pld-linux.org Git - packages/python3-wheezy.template.git/blob - python3-wheezy.template.spec
- updated to 2.0.0
[packages/python3-wheezy.template.git] / python3-wheezy.template.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4
5 Summary:        Leightweight template library
6 Summary(pl.UTF-8):      Lekka biblioteka szablonów
7 Name:           python3-wheezy.template
8 Version:        3.1.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/wheezy.template/
13 Source0:        https://files.pythonhosted.org/packages/source/w/wheezy.template/wheezy.template-%{version}.tar.gz
14 # Source0-md5:  007efefc10233bc723475c90e6dccb40
15 URL:            https://pypi.org/project/wheezy.template/
16 BuildRequires:  python3-Cython
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-pytest
21 %endif
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.714
24 Requires:       python3-modules >= 1:3.6
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 wheezy.template is a Python package written in pure Python code. It is
29 a lightweight template library. The design goals achieved:
30 - Compact, Expressive, Clean: Minimizes the number of keystrokes
31   required to build a template. Enables fast and well read coding.
32 - Intuitive, No time to Learn: Basic Python programming skills
33   plus HTML markup.
34 - Do Not Repeat Yourself: Master layout templates for inheritance;
35   include and import directives for maximum reuse.
36 - Blazingly Fast: Maximum rendering performance: ultimate speed and
37   context preprocessor features.
38
39 %description -l pl.UTF-8
40 wheezy.template to pakiet Pythona napisany w czystym Pythonie, będący
41 lekką biblioteką szablonów. Osiągnięte cele projektu:
42 - zwięzłość, wyrazistość, czystość: do stworzenia szablonu wymagana
43   jest minimalna liczba naciśnięć klawiszy. Pozwala to na szybkie i
44   czytelne kodowanie.
45 - intuicyjność, minimalny czas nauki: podstawy programowania w
46   Pythonie plus znaczniki HTML.
47 - brak powtarzania kodu: główne szablony wyglądu do dziedziczenia;
48   dyrektywy włączające i importujące, pozwalające na maksymalne
49   ponowne używanie.
50 - szybkość: duża wydajność renderowania.
51
52 %prep
53 %setup -q -n wheezy.template-%{version}
54
55 %build
56 %py3_build
57
58 %if %{with tests}
59 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
60 %{__python3} -m pytest
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %py3_install
67
68 %{__mv} $RPM_BUILD_ROOT%{_bindir}/wheezy.template{,-3}
69 ln -s wheezy-template-3 $RPM_BUILD_ROOT%{_bindir}/wheezy.template
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc LICENSE README.md
77 %attr(755,root,root) %{_bindir}/wheezy.template
78 %attr(755,root,root) %{_bindir}/wheezy.template-3
79 %dir %{py3_sitedir}/wheezy
80 %dir %{py3_sitedir}/wheezy/template
81 %{py3_sitedir}/wheezy/template/*.py
82 %{py3_sitedir}/wheezy/template/py.typed
83 %{py3_sitedir}/wheezy/template/__pycache__
84 %attr(755,root,root) %{py3_sitedir}/wheezy/template/*.cpython-*.so
85 %dir %{py3_sitedir}/wheezy/template/ext
86 %{py3_sitedir}/wheezy/template/ext/*.py
87 %{py3_sitedir}/wheezy/template/ext/__pycache__
88 %attr(755,root,root) %{py3_sitedir}/wheezy/template/ext/*.cpython-*.so
89 %{py3_sitedir}/wheezy.template-%{version}-py*-nspkg.pth
90 %{py3_sitedir}/wheezy.template-%{version}-py*.egg-info
This page took 0.182588 seconds and 3 git commands to generate.