]> git.pld-linux.org Git - packages/python3-vine.git/blob - python3-vine.spec
rebuild with python 3.10
[packages/python3-vine.git] / python3-vine.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module          vine
9 %define         egg_name        vine
10 %define         pypi_name       vine
11 Summary:        Python promises
12 Summary(pl.UTF-8):      Obietnice dla Pythona
13 Name:           python3-%{module}
14 Version:        5.0.0
15 Release:        3
16 License:        BSD
17 Group:          Libraries/Python
18 Source0:        https://files.pythonhosted.org/packages/source/v/vine/%{pypi_name}-%{version}.tar.gz
19 # Source0-md5:  2fc3270a999cdc9341ba173360d62367
20 URL:            https://vine.readthedocs.io/
21 BuildRequires:  python3-modules >= 1:3.6
22 BuildRequires:  python3-setuptools >= 1:20.6.7
23 %if %{with tests}
24 BuildRequires:  python3-case >= 1.3.1
25 BuildRequires:  python3-pytest >= 3.0
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 %if %{with doc}
30 BuildRequires:  python3-sphinx_celery >= 1.1
31 BuildRequires:  sphinx-pdg-3
32 %endif
33 Requires:       python3-modules >= 1:3.6
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Python promises.
39
40 %description -l pl.UTF-8
41 Obietnice (promise) dla Pythona.
42
43 %package apidocs
44 Summary:        API documentation for vine module
45 Summary(pl.UTF-8):      Dokumentacja API modułu vine
46 Group:          Documentation
47
48 %description apidocs
49 API documentation for vine module.
50
51 %description apidocs -l pl.UTF-8
52 Dokumentacja API modułu vine.
53
54 %prep
55 %setup -q -n %{pypi_name}-%{version}
56
57 %build
58 %py3_build
59
60 %if %{with tests}
61 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
62 PYTEST_PLUGINS="case.pytest" \
63 %{__python3} -m pytest t/unit
64 %endif
65
66 %if %{with doc}
67 %{__make} -C docs html \
68         SPHINXBUILD=sphinx-build-3
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %py3_install
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Changelog LICENSE README.rst
82 %{py3_sitescriptdir}/%{module}
83 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
84
85 %if %{with doc}
86 %files apidocs
87 %defattr(644,root,root,755)
88 %doc docs/_build/html/{_modules,_static,reference,*.html,*.js}
89 %endif
This page took 0.090153 seconds and 3 git commands to generate.