]> git.pld-linux.org Git - packages/python3-threadpoolctl.git/blob - python3-threadpoolctl.spec
rebuild with python 3.10
[packages/python3-threadpoolctl.git] / python3-threadpoolctl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (some build step needed)
4
5 Summary:        Thread-pool controls
6 Summary(pl.UTF-8):      Sterowanie pulą wątków
7 Name:           python3-threadpoolctl
8 Version:        2.0.0
9 Release:        3
10 License:        BSD
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/threadpoolctl/
13 Source0:        https://files.pythonhosted.org/packages/source/t/threadpoolctl/threadpoolctl-%{version}.tar.gz
14 # Source0-md5:  99bfceb7a7e9547c0ae98d74e382f328
15 URL:            https://pypi.org/project/threadpoolctl/
16 %if %{with tests}
17 BuildRequires:  python3-pytest
18 %endif
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 BuildRequires:  python3-modules >= 1:3.5
22 Requires:       python3-modules >= 1:3.5
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Python helpers to limit the number of threads used in the
28 threadpool-backed of common native libraries used for scientific
29 computing and data science (e.g. BLAS and OpenMP).
30
31 Fine control of the underlying thread-pool size can be useful in
32 workloads that involve nested parallelism so as to mitigate
33 oversubscription issues.
34
35 %description -l pl.UTF-8
36 Pythonowe funkcje pomocnicze do ograniczania liczby wątków używanych
37 przez korzystające z threadpoola popularne biblioteki natywne, służące
38 do obliczeń naukowych (np. BLAS czy OpenMP).
39
40 Dokładna kontrola rozmiaru puli wątków może być przydatna pod
41 obciążeniem związanym z zagnieżdżonym zrównolegleniem, a także pomóc
42 przy problemach ze zbyt dużym obciążeniem.
43
44 %prep
45 %setup -q -n threadpoolctl-%{version}
46
47 %build
48 %py3_build
49
50 %if %{with tests}
51 PYTHONPATH=$(pwd) \
52 %{__python3} -m pytest tests
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %py3_install
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CHANGES.md LICENSE README.md multiple_openmp.md
66 %{py3_sitescriptdir}/threadpoolctl.py
67 %{py3_sitescriptdir}/__pycache__/threadpoolctl.cpython-*.py[co]
68 %{py3_sitescriptdir}/threadpoolctl-%{version}-py*.egg-info
This page took 0.065 seconds and 3 git commands to generate.