]> git.pld-linux.org Git - packages/python3-sybil.git/blob - python3-sybil.spec
c1ceb683037901f366f54b61f6aa6aa2b136bdcd
[packages/python3-sybil.git] / python3-sybil.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 Summary:        Automated testing for the examples in your documentation
7 Summary(pl.UTF-8):      Automatyczne testowanie dla przykładów w dokumentacji
8 Name:           python3-sybil
9 Version:        3.0.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/sybil/
14 Source0:        https://files.pythonhosted.org/packages/source/s/sybil/sybil-%{version}.tar.gz
15 # Source0-md5:  fd8e33c2691eb042a16dfc179687592b
16 URL:            https://pypi.org/project/sybil/
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-pytest >= 6.2.0
21 BuildRequires:  python3-pytest-cov
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 %if %{with doc}
26 BuildRequires:  python3-furo
27 BuildRequires:  sphinx-pdg-3
28 %endif
29 Requires:       python3-modules >= 1:3.6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This library provides a way to test examples in your documentation by
35 parsing them from the documentation source and evaluating the parsed
36 examples as part of your normal test run. Integration is provided for
37 the main Python test runners.
38
39 %description -l pl.UTF-8
40 Ta biblioteka pozwala na testowanie przykładów w dokumentacji poprzez
41 ich analizę ze źródeł dokumentacji i wykonywanie jako części
42 normalnego uruchamiania testów. Zapewniona jest integracja z głównymi
43 sposobami uruchamiania testów w Pythonie.
44
45 %package apidocs
46 Summary:        API documentation for Python sybil module
47 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona sybil
48 Group:          Documentation
49
50 %description apidocs
51 API documentation for Python sybil module.
52
53 %description apidocs -l pl.UTF-8
54 Dokumentacja API modułu Pythona sybil.
55
56 %prep
57 %setup -q -n sybil-%{version}
58
59 %build
60 %py3_build
61
62 %if %{with tests}
63 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
64 %{__python3} -m pytest tests
65 %endif
66
67 %if %{with doc}
68 PYTHONPATH=$(pwd) \
69 %{__make} -C docs html \
70         SPHINXBUILD=sphinx-build-3
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %py3_install
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README.rst
84 %{py3_sitescriptdir}/sybil
85 %{py3_sitescriptdir}/sybil-%{version}-py*.egg-info
86
87 %if %{with doc}
88 %files apidocs
89 %defattr(644,root,root,755)
90 %doc docs/_build/html/{_static,*.html,*.js}
91 %endif
This page took 0.029289 seconds and 2 git commands to generate.