]> git.pld-linux.org Git - packages/python3-sphinxcontrib-towncrier.git/blob - python3-sphinxcontrib-towncrier.spec
bb3a4c40510e92ef0709950801f46036b3c70153
[packages/python3-sphinxcontrib-towncrier.git] / python3-sphinxcontrib-towncrier.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests
4 %bcond_without  doc     # Sphinx documentation
5
6 Summary:        An RST directive for injecting a Towncrier-generated changelog draft containing fragments for the unreleased (next) project version
7 Summary(pl.UTF-8):      Dyrektywa RST do wstawiania szablonu logu zmian z Towncriera, zawierajÄ…cego fragmenty dla kolejnej wersji projektu
8 Name:           python3-sphinxcontrib-towncrier
9 Version:        0.2.1a0
10 Release:        1
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/sphinxcontrib-towncrier/
14 Source0:        https://files.pythonhosted.org/packages/source/s/sphinxcontrib-towncrier/sphinxcontrib-towncrier-%{version}.tar.gz
15 # Source0-md5:  b315d29674b2af992e98ef762bcc9de0
16 URL:            https://pypi.org/project/sphinxcontrib-towncrier/
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 BuildRequires:  python3-setuptools_scm >= 3.5
20 BuildRequires:  python3-toml
21 %if %{with tests}
22 BuildRequires:  python3-Sphinx >= 1.7
23 BuildRequires:  python3-pytest
24 BuildRequires:  python3-pytest-xdist
25 BuildRequires:  python3-towncrier >= 19.2
26 %endif
27 %if %{with doc}
28 BuildRequires:  python3-furo >= 2021.02.28.beta28
29 BuildRequires:  python3-myst_parser >= 0.13.5
30 BuildRequires:  python3-sphinxcontrib-apidoc >= 0.3.0
31 # already installed package
32 BuildRequires:  python3-sphinxcontrib-towncrier
33 BuildRequires:  python3-towncrier >= 19.2
34 BuildRequires:  sphinx-pdg >= 3.5.1
35 %endif
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.714
38 BuildRequires:  sed >= 4.0
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 An RST directive for injecting a Towncrier-generated changelog draft
44 containing fragments for the unreleased (next) project version.
45
46 %description -l pl.UTF-8
47 Dyrektywa RST do wstawiania szablonu logu zmian z Towncriera,
48 zawierajÄ…cego fragmenty dla nie wydanej (kolejnej) wersji projektu.
49
50 %prep
51 %setup -q -n sphinxcontrib-towncrier-%{version}
52
53 %{__sed} -i -e '/^get_scm_version/ s/=.*/= lambda **kwargs : "%{version}"/' docs/conf.py
54
55 %build
56 %py3_build
57
58 %if %{with tests}
59 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
60 PYTEST_PLUGINS="xdist.plugin" \
61 PYTHONPATH=$(pwd) \
62 %{__python3} -m pytest tests
63 %endif
64
65 %if %{with doc}
66 sphinx-build-3 docs docs/_build/html
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %py3_install
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc LICENSE README.rst
80 %{py3_sitescriptdir}/sphinxcontrib/towncrier
81 %{py3_sitescriptdir}/sphinxcontrib_towncrier-%{version}-py*.egg-info
This page took 0.047106 seconds and 2 git commands to generate.