]> git.pld-linux.org Git - packages/python3-sphinxcontrib-asyncio.git/blob - python3-sphinxcontrib-asyncio.spec
ba24ab0e79115e759404bd898da67cb2ae14df09
[packages/python3-sphinxcontrib-asyncio.git] / python3-sphinxcontrib-asyncio.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (not included in sdist)
5
6 Summary:        Sphinx extension to support coroutines in markup
7 Summary(pl.UTF-8):      Rozszerzenie Sphinksa do obsługi korutyn w znacznikach
8 Name:           python3-sphinxcontrib-asyncio
9 Version:        0.3.0
10 Release:        2
11 License:        Apache v2
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/sphinxcontrib-asyncio/
14 Source0:        https://files.pythonhosted.org/packages/source/s/sphinxcontrib-asyncio/sphinxcontrib-asyncio-%{version}.tar.gz
15 # Source0-md5:  5445823a927f3368dd81b9061bec0055
16 URL:            https://pypi.org/project/sphinxcontrib-asyncio/
17 BuildRequires:  python3-modules >= 1:3.5
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-Sphinx >= 3.0
21 BuildRequires:  python3-pytest
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 %if %{with doc}
26 BuildRequires:  sphinx-pdg >= 3.0
27 %endif
28 Requires:       python3-modules >= 1:3.5
29 Requires:       python-sphinxcontrib
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Sphinx extension for adding asyncio-specific markups.
35
36 %description -l pl.UTF-8
37 Rozszerzenie Sphinksa do dodawania oznaczeń specyficznych dla asyncio.
38
39 %package apidocs
40 Summary:        API documentation for Python sphinxcontrib-asyncio module
41 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona sphinxcontrib-asyncio
42 Group:          Documentation
43
44 %description apidocs
45 API documentation for Python sphinxcontrib-asyncio module.
46
47 %description apidocs -l pl.UTF-8
48 Dokumentacja API modułu Pythona sphinxcontrib-asyncio.
49
50 %prep
51 %setup -q -n sphinxcontrib-asyncio-%{version}
52
53 %build
54 %py3_build
55
56 %if %{with tests}
57 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
58 %{__python3} -m pytest tests
59 %endif
60
61 %if %{with doc}
62 PYTHONPATH=$(pwd) \
63 %{__make} -C docs html
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %py3_install
70
71 # provides by python3-sphinxcontrib in PLD
72 %{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/sphinxcontrib/__init__.py \
73         $RPM_BUILD_ROOT%{py3_sitescriptdir}/sphinxcontrib/__pycache__/__init__.*.py*
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CHANGES.rst README.rst
81 %{py3_sitescriptdir}/sphinxcontrib/asyncio.py
82 %{py3_sitescriptdir}/sphinxcontrib/__pycache__/asyncio.cpython-*.py[co]
83 %{py3_sitescriptdir}/sphinxcontrib_asyncio-%{version}-py*.egg-info
84
85 %if %{with doc}
86 %files apidocs
87 %defattr(644,root,root,755)
88 %doc docs/_build/html/{_modules,_static,*.html,*.js}
89 %endif
This page took 0.170472 seconds and 2 git commands to generate.