]> git.pld-linux.org Git - packages/python3-sphinxcontrib-asyncio.git/blob - python3-sphinxcontrib-asyncio.spec
1ac5029fac0c615d93698549c4a04216801b58ca
[packages/python3-sphinxcontrib-asyncio.git] / python3-sphinxcontrib-asyncio.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (not included in sdist)
5
6 Summary:        Sphinx extension to support coroutines in markup
7 Summary(pl.UTF-8):      Rozszerzenie Sphinksa do obsługi korutyn w znacznikach
8 Name:           python3-sphinxcontrib-asyncio
9 Version:        0.3.0
10 Release:        3
11 License:        Apache v2
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/sphinxcontrib-asyncio/
14 Source0:        https://files.pythonhosted.org/packages/source/s/sphinxcontrib-asyncio/sphinxcontrib-asyncio-%{version}.tar.gz
15 # Source0-md5:  5445823a927f3368dd81b9061bec0055
16 URL:            https://pypi.org/project/sphinxcontrib-asyncio/
17 BuildRequires:  python3-modules >= 1:3.5
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-Sphinx >= 3.0
21 BuildRequires:  python3-pytest
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 %if %{with doc}
26 # requires already installed package
27 BuildRequires:  python3-sphinxcontrib-asyncio
28 BuildRequires:  sphinx-pdg >= 3.0
29 %endif
30 Requires:       python3-modules >= 1:3.5
31 Requires:       python3-sphinxcontrib
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Sphinx extension for adding asyncio-specific markups.
37
38 %description -l pl.UTF-8
39 Rozszerzenie Sphinksa do dodawania oznaczeń specyficznych dla asyncio.
40
41 %package apidocs
42 Summary:        API documentation for Python sphinxcontrib-asyncio module
43 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona sphinxcontrib-asyncio
44 Group:          Documentation
45
46 %description apidocs
47 API documentation for Python sphinxcontrib-asyncio module.
48
49 %description apidocs -l pl.UTF-8
50 Dokumentacja API modułu Pythona sphinxcontrib-asyncio.
51
52 %prep
53 %setup -q -n sphinxcontrib-asyncio-%{version}
54
55 %build
56 %py3_build
57
58 %if %{with tests}
59 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
60 %{__python3} -m pytest tests
61 %endif
62
63 %if %{with doc}
64 PYTHONPATH=$(pwd) \
65 %{__make} -C docs html
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %py3_install
72
73 # provides by python3-sphinxcontrib in PLD
74 %{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/sphinxcontrib/__init__.py \
75         $RPM_BUILD_ROOT%{py3_sitescriptdir}/sphinxcontrib/__pycache__/__init__.*.py*
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc CHANGES.rst README.rst
83 %{py3_sitescriptdir}/sphinxcontrib/asyncio.py
84 %{py3_sitescriptdir}/sphinxcontrib/__pycache__/asyncio.cpython-*.py[co]
85 %{py3_sitescriptdir}/sphinxcontrib_asyncio-%{version}-py*.egg-info
86
87 %if %{with doc}
88 %files apidocs
89 %defattr(644,root,root,755)
90 %doc docs/_build/html/{_modules,_static,*.html,*.js}
91 %endif
This page took 0.051535 seconds and 2 git commands to generate.