]> git.pld-linux.org Git - packages/python3-smspdudecoder.git/blob - python3-smspdudecoder.spec
be51dd3082cc1d9c7aa064c7f50ea9cb0cf6c571
[packages/python3-smspdudecoder.git] / python3-smspdudecoder.spec
1 # Conditional build:
2 %bcond_with     tests   # unit tests
3
4 %define         module          smspdu
5 %define         egg_name        smspdudecoder
6 %define         pypi_name       smspdudecoder
7 Summary:        SMS-PDU Decoder
8 Name:           python3-%{pypi_name}
9 Version:        1.1.0
10 Release:        3
11 License:        MIT
12 Group:          Libraries/Python
13 Source0:        https://github.com/Qotto/smspdudecoder/archive/%{version}.tar.gz
14 # Source0-md5:  d76e2a506ee62364399cc3e46de41aaf
15 URL:            https://github.com/Qotto/smspdudecoder/
16 BuildRequires:  python3-modules >= 1:3.6
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with tests}
20 BuildRequires:  python3-bitstring
21 %endif
22 BuildRequires:  python3-setuptools
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This library will help you to decode raw SMS data you can get from a
28 GSM modem.
29
30 It has some encoding functionality as well.
31
32 It is recommended to read GSM 03.40 to facilitate understanding.
33
34 %prep
35 %setup -q -n %{pypi_name}-%{version}
36
37 %build
38 %py3_build %{?with_tests:test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %py3_install
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README.md
51 %{py3_sitescriptdir}/%{module}
52 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.076949 seconds and 2 git commands to generate.