]> git.pld-linux.org Git - packages/python3-skia-pathops.git/blob - python3-skia-pathops.spec
6d649e371614156782cb7d2c21471a51b39351f0
[packages/python3-skia-pathops.git] / python3-skia-pathops.spec
1 # TODO: system skia? (BUILD_SKIA_FROM_SOURCE=0, BR: skia.pc)
2 #
3 # Conditional build:
4 %bcond_without  tests   # unit tests
5
6 Summary:        Boolean operations on paths using the Skia library
7 Summary(pl.UTF-8):      Operacje logiczne na ścieżkach przy użyciu biblioteki Skia
8 Name:           python3-skia-pathops
9 Version:        0.7.2
10 Release:        2
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/skia-pathops/
14 #Source0:       https://files.pythonhosted.org/packages/source/s/skia-pathops/skia-pathops-%{version}.zip
15 Source0:        https://files.pythonhosted.org/packages/60/4e/73eb87157e23169a901f16773ccd7dd44b8394346beeaaab7dcadb187518/skia-pathops-%{version}.zip
16 # Source0-md5:  c4455e40f408c1c5931d72dc9f4f2005
17 Patch0:         %{name}-build.patch
18 URL:            https://pypi.org/project/skia-pathops/
19 BuildRequires:  gn
20 BuildRequires:  libstdc++-devel >= 6:5
21 BuildRequires:  ninja
22 BuildRequires:  python3-Cython >= 0.28.4
23 BuildRequires:  python3-devel >= 1:3.7
24 BuildRequires:  python3-setuptools
25 %if %{with tests}
26 BuildRequires:  python3-pytest >= 3.0.0
27 BuildRequires:  python3-pytest-cython
28 #BuildRequires: python3-pytest-randomly >= 1.2.3
29 #BuildRequires: python3-pytest-xdist >= 1.22.2
30 %endif
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.714
33 BuildRequires:  unzip
34 Requires:       python3-modules >= 1:3.7
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Python bindings for the Google Skia library's Path Ops module,
39 performing boolean operations on paths (intersection, union,
40 difference, xor).
41
42 %description -l pl.UTF-8
43 Wiązania Pythona do modułu Path Ops biblioteki Google Skia,
44 wykonującego operacje logiczne na ścieżkach (przecięcia, sumy,
45 różnice, różnice symetryczne).
46
47 %prep
48 %setup -q -n skia-pathops-%{version}
49 %patch0 -p1
50
51 %build
52 %py3_build
53
54 %if %{with tests}
55 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
56 PYTEST_PLUGINS="pytest_cython.plugin" \
57 PYTHONPATH=$(echo $(pwd)/build-3/lib.*) \
58 %{__python3} -m pytest tests
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %py3_install
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc LICENSE README.md
72 %dir %{py3_sitedir}/pathops
73 %{py3_sitedir}/pathops/*.py
74 %attr(755,root,root) %{py3_sitedir}/pathops/_pathops.cpython-*.so
75 %{py3_sitedir}/pathops/__pycache__
76 %{py3_sitedir}/skia_pathops-%{version}-py*.egg-info
This page took 0.087063 seconds and 2 git commands to generate.