]> git.pld-linux.org Git - packages/python3-setuptools_scm.git/blob - python3-setuptools_scm.spec
- release 2
[packages/python3-setuptools_scm.git] / python3-setuptools_scm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # py.test tests
4 %bcond_with     tests_scm       # py.test tests using SCM programs (git, hg)
5
6 Summary:        Python 3 package to manager versions by scm tags
7 Summary(pl.UTF-8):      Pakiet Pythona 3 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
8 Name:           python3-setuptools_scm
9 Version:        6.4.2
10 Release:        2
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/setuptools_scm/
14 Source0:        https://files.pythonhosted.org/packages/source/s/setuptools_scm/setuptools_scm-%{version}.tar.gz
15 # Source0-md5:  b4e02bf8e62ed49142ea7b42a68671d7
16 URL:            https://github.com/pypa/setuptools_scm
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-packaging >= 20.0
19 BuildRequires:  python3-setuptools >= 1:45
20 BuildRequires:  python3-tomli >= 1.0.0
21 %if %{with tests}
22 BuildRequires:  python3-pytest >= 3.1.0
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 %if %{with tests_scm}
27 BuildRequires:  git-core
28 BuildRequires:  mercurial
29 %endif
30 Requires:       python3-setuptools >= 1:45
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 setuptools_scm is a simple utility for the setup_requires feature of
36 setuptools for use in Mercurial and Git based projects.
37
38 %description -l pl.UTF-8
39 setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
40 setuptools przeznaczone do stosowania w projektach opatych na
41 systemach kontroli wersji Mercurial i Git.
42
43 %prep
44 %setup -q -n setuptools_scm-%{version}
45
46 %if %{without tests_scm}
47 %{__rm} testing/test_{file_finder,git,mercurial,regressions}.py
48 %endif
49
50 # tries to install using pip
51 %{__rm} testing/test_setuptools_support.py
52
53 %build
54 %py3_build
55
56 %if %{with tests}
57 PYTHONPATH=$(pwd)/src \
58 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
59 %{__python3} -m pytest testing
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %py3_install
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc CHANGELOG.rst LICENSE README.rst
73 %{py3_sitescriptdir}/setuptools_scm
74 %{py3_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
This page took 0.077841 seconds and 3 git commands to generate.