]> git.pld-linux.org Git - packages/python3-setuptools_scm.git/blob - python3-setuptools_scm.spec
- up to 6.4.2
[packages/python3-setuptools_scm.git] / python3-setuptools_scm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # py.test tests
4 %bcond_with     tests_scm       # py.test tests using SCM programs (git, hg)
5
6 Summary:        Python 3 package to manager versions by scm tags
7 Summary(pl.UTF-8):      Pakiet Pythona 3 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
8 Name:           python3-setuptools_scm
9 Version:        6.4.2
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/setuptools_scm/
14 Source0:        https://files.pythonhosted.org/packages/source/s/setuptools_scm/setuptools_scm-%{version}.tar.gz
15 # Source0-md5:  b4e02bf8e62ed49142ea7b42a68671d7
16 URL:            https://github.com/pypa/setuptools_scm
17 BuildRequires:  python3-modules >= 1:3.5
18 BuildRequires:  python3-setuptools >= 1:42
19 %if %{with tests}
20 BuildRequires:  python3-py >= 1.4.26
21 BuildRequires:  python3-pytest >= 3.1.0
22 BuildRequires:  python3-toml
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 %if %{with tests_scm}
27 BuildRequires:  git-core
28 BuildRequires:  mercurial
29 %endif
30 Requires:       python3-setuptools
31 Requires:       python3-toml
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 setuptools_scm is a simple utility for the setup_requires feature of
37 setuptools for use in Mercurial and Git based projects.
38
39 %description -l pl.UTF-8
40 setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
41 setuptools przeznaczone do stosowania w projektach opatych na
42 systemach kontroli wersji Mercurial i Git.
43
44 %prep
45 %setup -q -n setuptools_scm-%{version}
46
47 %if %{without tests_scm}
48 %{__rm} testing/test_{file_finder,git,mercurial,regressions}.py
49 %endif
50
51 # tries to install using pip
52 %{__rm} testing/test_setuptools_support.py
53
54 %build
55 %py3_build
56
57 %if %{with tests}
58 PYTHONPATH=$(pwd)/src \
59 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
60 %{__python3} -m pytest testing
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %py3_install
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc CHANGELOG.rst LICENSE README.rst
74 %{py3_sitescriptdir}/setuptools_scm
75 %{py3_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
This page took 0.300079 seconds and 3 git commands to generate.