]> git.pld-linux.org Git - packages/python3-secretstorage.git/blob - python3-secretstorage.spec
- updated to 3.3.3
[packages/python3-secretstorage.git] / python3-secretstorage.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (require dbus stub or some Secret Service daemon running, e.g. GNOME Keyring)
5
6 Summary:        Python 3 bindings to Freedesktop.org Secret Service API
7 Summary(pl.UTF-8):      Wiązania Pythona 3 do API Secret Service z Freedesktop.org
8 Name:           python3-secretstorage
9 Version:        3.3.3
10 Release:        1
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/secretstorage/
14 Source0:        https://files.pythonhosted.org/packages/source/S/SecretStorage/SecretStorage-%{version}.tar.gz
15 # Source0-md5:  c6ff1cc866d2f1d274b75c6490726b1b
16 URL:            https://github.com/mitya57/secretstorage
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools >= 1:30.3
19 %if %{with doc}
20 BuildRequires:  python3-Sphinx
21 %endif
22 %if %{with tests}
23 BuildRequires:  dbus
24 BuildRequires:  python3-cryptography >= 2.0
25 BuildRequires:  python3-jeepney >= 0.6
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 Requires:       python3-modules >= 1:3.6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This module provides a way for securely storing passwords and other
35 secrets.
36
37 It uses D-Bus Secret Service API that is supported by GNOME Keyring
38 (since version 2.30) and KSecretsService.
39
40 %description -l pl.UTF-8
41 Ten moduł udostępnia sposób bezpiecznego przechowywania haseł i innych
42 tajnych danych.
43
44 Wykorzystuje API D-Bus Secret Service, obsługiwane przez GNOME Keyring
45 (od wersji 2.30) oraz KSecretsService.
46
47 %package apidocs
48 Summary:        secretstorage API documentation
49 Summary(pl.UTF-8):      Dokumentacja API secretstorage
50 Group:          Documentation
51
52 %description apidocs
53 API documentation for secretstorage.
54
55 %description apidocs -l pl.UTF-8
56 Dokumentacja API secretstorage.
57
58 %prep
59 %setup -q -n SecretStorage-%{version}
60
61 %build
62 %py3_build %{?with_doc:build_sphinx}
63
64 %if %{with tests}
65 dbus-run-session -- %{__python3} -m unittest discover -s tests
66 %endif
67
68 %install
69 %py3_install
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc LICENSE README.rst changelog
77 %{py3_sitescriptdir}/secretstorage
78 %{py3_sitescriptdir}/SecretStorage-%{version}-py*.egg-info
79
80 %if %{with doc}
81 %files apidocs
82 %defattr(644,root,root,755)
83 %doc build-3/sphinx/html/{_static,*.html,*.js}
84 %endif
This page took 0.064421 seconds and 3 git commands to generate.