]> git.pld-linux.org Git - packages/python3-secretstorage.git/blob - python3-secretstorage.spec
1630e6d8815ca36f2a0a5f72fce801c17e064978
[packages/python3-secretstorage.git] / python3-secretstorage.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests [require dbus and some Secret Service daemon running]
5
6 Summary:        Python 3 bindings to Freedesktop.org Secret Service API
7 Summary(pl.UTF-8):      Wiązania Pythona 3 do API Secret Service z Freedesktop.org
8 Name:           python3-secretstorage
9 Version:        3.1.2
10 Release:        1
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/secretstorage/
14 Source0:        https://files.pythonhosted.org/packages/source/S/SecretStorage/SecretStorage-%{version}.tar.gz
15 # Source0-md5:  c2a8c0e08e5da198fc38c379b98c28f1
16 URL:            https://github.com/mitya57/secretstorage
17 BuildRequires:  python3-modules >= 1:3.5
18 BuildRequires:  python3-setuptools
19 %if %{with doc}
20 BuildRequires:  python3-Sphinx
21 %endif
22 %if %{with tests}
23 BuildRequires:  python3-cryptography
24 BuildRequires:  python3-jeepney >= 0.4.2
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       python3-modules >= 1:3.5
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module provides a way for securely storing passwords and other
34 secrets.
35
36 It uses D-Bus Secret Service API that is supported by GNOME Keyring
37 (since version 2.30) and KSecretsService.
38
39 %description -l pl.UTF-8
40 Ten moduł udostępnia sposób bezpiecznego przechowywania haseł i innych
41 tajnych danych.
42
43 Wykorzystuje API D-Bus Secret Service, obsługiwane przez GNOME Keyring
44 (od wersji 2.30) oraz KSecretsService.
45
46 %package apidocs
47 Summary:        secretstorage API documentation
48 Summary(pl.UTF-8):      Dokumentacja API secretstorage
49 Group:          Documentation
50
51 %description apidocs
52 API documentation for secretstorage.
53
54 %description apidocs -l pl.UTF-8
55 Dokumentacja API secretstorage.
56
57 %prep
58 %setup -q -n SecretStorage-%{version}
59
60 %build
61 %py3_build %{?with_doc:build_sphinx}
62
63 %if %{with tests}
64 # TODO: proper value
65 export DBUS_SESSION_BUS_ADDRESS=???
66 %{__python3} tests/run_tests.py
67 %endif
68
69 %install
70 %py3_install
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc LICENSE README.rst changelog
78 %{py3_sitescriptdir}/secretstorage
79 %{py3_sitescriptdir}/SecretStorage-%{version}-py*.egg-info
80
81 %if %{with doc}
82 %files apidocs
83 %defattr(644,root,root,755)
84 %doc build-3/sphinx/html/{_static,*.html,*.js}
85 %endif
This page took 0.044499 seconds and 2 git commands to generate.