]> git.pld-linux.org Git - packages/python3-s3transfer.git/blob - python3-s3transfer.spec
rebuild with tests and docs
[packages/python3-s3transfer.git] / python3-s3transfer.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        Amazon S3 Transfer Manager
6 Summary(pl.UTF-8):      Zarządca transferu danych Amazon S3
7 Name:           python3-s3transfer
8 Version:        0.5.0
9 Release:        4
10 License:        Apache v2.0
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/s3transfer/
13 Source0:        https://files.pythonhosted.org/packages/source/s/s3transfer/s3transfer-%{version}.tar.gz
14 # Source0-md5:  9416d1c7d33506501a8627bb1f7baf66
15 Patch0:         %{name}-mock.patch
16 Patch1:         %{name}-tests.patch
17 URL:            https://pypi.org/project/s3transfer/
18 BuildRequires:  python3-modules >= 1:3.6
19 BuildRequires:  python3-setuptools
20 %if %{with tests}
21 BuildRequires:  python3-botocore >= 1.12.36
22 BuildRequires:  python3-nose >= 1.3.3
23 BuildRequires:  python3-six
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python3-modules >= 1:3.6
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 S3transfer is a Python library for managing Amazon S3 transfers.
33
34 %description -l pl.UTF-8
35 S3transfer to pythonowa biblioteka do zarządzania przesyłami danych
36 Amazon S3.
37
38 %prep
39 %setup -q -n s3transfer-%{version}
40 %patch0 -p1
41 %patch1 -p1
42
43 %build
44 %py3_build
45
46 %if %{with tests}
47 %{__python3} -m unittest discover -s tests/unit
48 %endif
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %py3_install
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README.rst
61 %{py3_sitescriptdir}/s3transfer
62 %{py3_sitescriptdir}/s3transfer-%{version}-py*.egg-info
This page took 0.078791 seconds and 3 git commands to generate.