]> git.pld-linux.org Git - packages/python3-rsa.git/blob - python3-rsa.spec
118433fae17068f28d1e6e280cf69711bcc2dc01
[packages/python3-rsa.git] / python3-rsa.spec
1 %define         module  rsa
2 Summary:        Pure-Python RSA implementation
3 Name:           python3-%{module}
4 Version:        4.7.2
5 Release:        2
6 License:        Apache v2.0
7 Group:          Libraries/Python
8 #Source0Download: https://pypi.org/simple/rsa/
9 Source0:        https://files.pythonhosted.org/packages/source/r/rsa/%{module}-%{version}.tar.gz
10 # Source0-md5:  c21701cdd75c170f8d690f704a362c44
11 URL:            https://pypi.org/project/rsa/
12 BuildRequires:  python3-modules >= 1:3.5
13 BuildRequires:  python3-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 Requires:       python3-modules >= 1:3.5
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Python-RSA is a pure-Python RSA implementation. It supports encryption
22 and decryption, signing and verifying signatures, and key generation
23 according to PKCS#1 version 1.5. It can be used as a Python library as
24 well as on the commandline.
25
26 %prep
27 %setup -q -n %{module}-%{version}
28
29 %build
30 %py3_build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 %py3_install
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc README.md
43 %attr(755,root,root) %{_bindir}/pyrsa-decrypt
44 %attr(755,root,root) %{_bindir}/pyrsa-encrypt
45 %attr(755,root,root) %{_bindir}/pyrsa-keygen
46 %attr(755,root,root) %{_bindir}/pyrsa-priv2pub
47 %attr(755,root,root) %{_bindir}/pyrsa-sign
48 %attr(755,root,root) %{_bindir}/pyrsa-verify
49 %dir %{py3_sitescriptdir}/%{module}
50 %{py3_sitescriptdir}/%{module}/*.py
51 %{py3_sitescriptdir}/%{module}/__pycache__
52 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.075231 seconds and 2 git commands to generate.