]> git.pld-linux.org Git - packages/python3-repomd.git/blob - python3-repomd.spec
f176c8b867a1e632fca22f6a1f1ecf2579ccfa76
[packages/python3-repomd.git] / python3-repomd.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # don't build doc
4 %bcond_without  tests   # do not perform "make test"
5
6 %define         module          repomd
7 %define         egg_name        repomd
8 %define         pypi_name       repomd
9 Summary:        Library for reading dnf/yum repositories
10 Name:           python3-%{pypi_name}
11 Version:        0.1.0
12 Release:        0.1
13 License:        MIT
14 Group:          Libraries/Python
15 Source0:        https://files.pythonhosted.org/packages/source/r/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  f781a03ba41afb662843aca196a221ea
17 URL:            https://github.com/carlwgeorge/repomd
18 BuildRequires:  python3-modules
19 BuildRequires:  python3-setuptools >= 38.6.0
20 %if %{with tests}
21 BuildRequires:  python3-lxml
22 BuildRequires:  python3-pytest
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This library provides an object-oriented interface to get information
31 out of dnf/yum repositories.
32
33 %prep
34 %setup -q -n %{pypi_name}-%{version}
35
36 %build
37 %py3_build %{?with_tests:test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %py3_install
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README.md
49 %{py3_sitescriptdir}/%{pypi_name}.py
50 %{py3_sitescriptdir}/__pycache__/*
51 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.060114 seconds and 2 git commands to generate.