]> git.pld-linux.org Git - packages/python3-repomd.git/blob - python3-repomd.spec
rebuild with tests and docs
[packages/python3-repomd.git] / python3-repomd.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         module          repomd
6 %define         egg_name        repomd
7 %define         pypi_name       repomd
8 Summary:        Library for reading dnf/yum repositories
9 Summary(pl.UTF-8):      Biblioteka do odczytu repozytoriów dnf/yum
10 Name:           python3-%{pypi_name}
11 Version:        0.2.1
12 Release:        5
13 License:        MIT
14 Group:          Libraries/Python
15 Source0:        https://files.pythonhosted.org/packages/source/r/repomd/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  3979bcf59644ead9fb3324fe36d183ed
17 URL:            https://github.com/carlwgeorge/repomd
18 BuildRequires:  python3-modules
19 BuildRequires:  python3-setuptools >= 1:38.6.0
20 %if %{with tests}
21 BuildRequires:  python3-lxml
22 BuildRequires:  python3-pytest
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This library provides an object-oriented interface to get information
31 out of dnf/yum repositories.
32
33 %description -l pl.UTF-8
34 Ta biblioteka udostępnia obiektowo zorientowany interfejs do
35 pobierania informacji z repozytoriów dnf/yum.
36
37 %prep
38 %setup -q -n %{pypi_name}-%{version}
39
40 %build
41 %py3_build %{?with_tests:test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %py3_install
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README.md
54 %{py3_sitescriptdir}/%{module}.py
55 %{py3_sitescriptdir}/__pycache__/%{module}.cpython-*.py[co]
56 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.072075 seconds and 3 git commands to generate.