]> git.pld-linux.org Git - packages/python3-pyxattr.git/blob - python3-pyxattr.spec
rebuild with python 3.10
[packages/python3-pyxattr.git] / python3-pyxattr.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 %define         module  pyxattr
7 Summary:        Python 3 module for accessing Extended Attributes of the files
8 Summary(pl.UTF-8):      Moduł Pythona 3 pozwalający na dostęp do rozszerzonych atrybutów plików
9 Name:           python3-%{module}
10 Version:        0.7.1
11 Release:        4
12 License:        LGPL v2.1+
13 Group:          Libraries/Python
14 Source0:        https://pyxattr.k1024.org/downloads/%{module}-%{version}.tar.gz
15 # Source0-md5:  f3341e703489452afaf68b336be5d32c
16 URL:            https://pyxattr.k1024.org/
17 BuildRequires:  python3-devel >= 1:3.4
18 BuildRequires:  python3-modules >= 1:3.4
19 BuildRequires:  python3-setuptools
20 %if %{with tests}
21 BuildRequires:  python3-pytest
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 %if %{with doc}
26 BuildRequires:  python3-recommonmark
27 BuildRequires:  sphinx-pdg-3
28 %endif
29 Requires:       python3-libs >= 1:3.4
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Python 3 module for accessing Extended Attributes of the files.
34
35 %description -l pl.UTF-8
36 Moduł Pythona 3 pozwalający na dostęp do rozszerzonych atrybutów
37 plików.
38
39 %prep
40 %setup -q -n %{module}-%{version}
41
42 %build
43 %py3_build
44
45 %if %{with tests}
46 PYTHONPATH=$(echo $(pwd)/build-3/lib.*) \
47 %{__python3} -m pytest test
48 %endif
49
50 %if %{with doc}
51 sphinx-build-3 -b html doc doc/_build/html
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %py3_install
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc NEWS README.md
65 %attr(755,root,root) %{py3_sitedir}/xattr.cpython-*.so
66 %{py3_sitedir}/pyxattr-%{version}-py*.egg-info
This page took 0.108149 seconds and 3 git commands to generate.