]> git.pld-linux.org Git - packages/python3-pythran.git/blob - python3-pythran.spec
- python-pythran.spec updated to 0.11.0 for python3
[packages/python3-pythran.git] / python3-pythran.spec
1 # TODO: finish docs
2 #
3 # Conditional build:
4 %bcond_with     doc     # Sphinx documentation
5 %bcond_with     tests   # unit tests (missing in sdist)
6
7 Summary:        Ahead of Time compiler for numeric kernels
8 Summary(pl.UTF-8):      Kompilator z wyprzedzeniem dla jąder numerycznych
9 Name:           python3-pythran
10 Version:        0.11.0
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/pythran/
15 Source0:        https://files.pythonhosted.org/packages/source/p/pythran/pythran-%{version}.tar.gz
16 # Source0-md5:  e09e90484771937ab499380858bdb18d
17 URL:            https://pypi.org/project/pythran/
18 BuildRequires:  python3-modules >= 1:3.2
19 BuildRequires:  python3-pytest-runner
20 BuildRequires:  python3-setuptools >= 1:12.0.5
21 %if %{with tests}
22 BuildRequires:  python3-beniget >= 0.4.0
23 BuildRequires:  python3-beniget < 0.5
24 BuildRequires:  python3-gast >= 0.5.0
25 BuildRequires:  python3-gast < 0.6
26 BuildRequires:  python3-numpy
27 BuildRequires:  python3-ply >= 3.4
28 %endif
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.714
31 %if %{with doc}
32 BuildRequires:  python3-guzzle_sphinx_theme
33 BuildRequires:  python3-nbsphinx
34 BuildRequires:  python3-numpy
35 BuildRequires:  python3-scipy
36 BuildRequires:  sphinx-pdg-3
37 %endif
38 Requires:       python3-modules >= 1:3.2
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Pythran is an ahead of time compiler for a subset of the Python
44 language, with a focus on scientific computing. It takes a Python
45 module annotated with a few interface description and turns it into a
46 native Python module with the same interface, but (hopefully) faster.
47
48 %description -l pl.UTF-8
49 Pythran to kompilator z wyprzedzeniem dla podzbioru języka Python,
50 skupiający się na obliczeniach naukowych. Przyjmuje moduł Pythona z
51 niewielkim opisem interfejsu i zamienia go na natywny moduł Pythona o
52 tym samym interfejsie, ale (miejmy nadzieję) szybszy.
53
54 %package apidocs
55 Summary:        API documentation for Python pythran module
56 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona pythran
57 Group:          Documentation
58
59 %description apidocs
60 API documentation for Python pythran module.
61
62 %description apidocs -l pl.UTF-8
63 Dokumentacja API modułu Pythona pythran.
64
65 %prep
66 %setup -q -n pythran-%{version}
67
68 %build
69 %py3_build %{?with_tests:test}
70
71 %if %{with doc}
72 %{__make} -C docs html \
73         SPHINXBUILD=sphinx-build-3
74 %endif
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %py3_install
80
81 %{__mv} $RPM_BUILD_ROOT%{_bindir}/pythran{,-3}
82 %{__mv} $RPM_BUILD_ROOT%{_bindir}/pythran-config{,-3}
83 ln -sf pythran-3 $RPM_BUILD_ROOT%{_bindir}/pythran
84 ln -sf pythran-config-3 $RPM_BUILD_ROOT%{_bindir}/pythran-config
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS Changelog LICENSE README.rst
92 %attr(755,root,root) %{_bindir}/pythran
93 %attr(755,root,root) %{_bindir}/pythran-3
94 %attr(755,root,root) %{_bindir}/pythran-config
95 %attr(755,root,root) %{_bindir}/pythran-config-3
96 %{py3_sitescriptdir}/omp
97 %{py3_sitescriptdir}/pythran
98 %{py3_sitescriptdir}/pythran-%{version}-py*.egg-info
99
100 %if %{with doc}
101 %files apidocs
102 %defattr(644,root,root,755)
103 %doc docs/_build/html/*
104 %endif
This page took 0.097857 seconds and 3 git commands to generate.