]> git.pld-linux.org Git - packages/python3-pytest-randomly.git/blob - python3-pytest-randomly.spec
rebuild with python 3.10
[packages/python3-pytest-randomly.git] / python3-pytest-randomly.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4
5 Summary:        Pytest plugin to randomly order tests and control random.seed
6 Summary(pl.UTF-8):      Wtyczka pytesta do losowej kolejności testów i sterowania random.seed
7 Name:           python3-pytest-randomly
8 Version:        3.11.0
9 Release:        2
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/pytest-randomly/
13 Source0:        https://files.pythonhosted.org/packages/source/p/pytest-randomly/pytest-randomly-%{version}.tar.gz
14 # Source0-md5:  13cf321031de846c969aa5522a01ec40
15 URL:            https://pypi.org/project/pytest-randomly/
16 BuildRequires:  python3-modules >= 1:3.7
17 BuildRequires:  python3-setuptools >= 1:40.6.0
18 %if %{with tests}
19 BuildRequires:  python3-factory_boy
20 BuildRequires:  python3-faker
21 %if "%{_ver_lt '%{py3_ver}' '3.10'}" == "1"
22 BuildRequires:  python3-importlib-metadata >= 3.6.0
23 %endif
24 BuildRequires:  python3-numpy
25 BuildRequires:  python3-pytest
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.750
29 Requires:       python3-modules >= 1:3.7
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Pytest plugin to randomly order tests and control random.seed.
35
36 %description -l pl.UTF-8
37 Wtyczka pytesta do losowej kolejności testów i sterowania random.seed.
38
39 %prep
40 %setup -q -n pytest-randomly-%{version}
41
42 %build
43 %py3_build
44
45 %if %{with tests}
46 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
47 PYTEST_PLUGINS="pytester,pytest_randomly" \
48 %{__python3} -m pytest tests
49 %endif
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %py3_install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc HISTORY.rst LICENSE README.rst
62 %{py3_sitescriptdir}/pytest_randomly
63 %{py3_sitescriptdir}/pytest_randomly-%{version}-py*.egg-info
This page took 0.074509 seconds and 3 git commands to generate.