]> git.pld-linux.org Git - packages/python3-pytest-cython.git/blob - python3-pytest-cython.spec
- python-pytest-cython.spec updated to 0.2.0 for python 3.6+
[packages/python3-pytest-cython.git] / python3-pytest-cython.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 Summary:        Plugin for testing Cython extension modules
7 Summary(pl.UTF-8):      Wtyczka do testowania modułów rozszerzeń Cythona
8 Name:           python3-pytest-cython
9 Version:        0.2.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/pytest-cython/
14 Source0:        https://files.pythonhosted.org/packages/source/p/pytest-cython/pytest-cython-%{version}.tar.gz
15 # Source0-md5:  4efc5b43e0b10f3995f14bda0eeebce0
16 URL:            https://pypi.org/project/pytest-cython/
17 %{?with_tests:BuildRequires:    libstdc++-devel}
18 BuildRequires:  python3-modules >= 1:3.6
19 BuildRequires:  python3-setuptools
20 %if %{with tests}
21 BuildRequires:  python3-Cython >= 0.28
22 BuildRequires:  python3-pytest >= 4.6.0
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 %if %{with doc}
27 BuildRequires:  python3-sphinx_py3doc_enhanced_theme
28 BuildRequires:  sphinx-pdg-3 >= 1.3
29 %endif
30 Requires:       python3-modules >= 1:3.6
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This Pytest plugin allows for the doctesting of C extension modules
36 for Python, specifically created through Cython.
37
38 %description -l pl.UTF-8
39 Ta wtyczka Pytesta pozwala wykonywać doctesty modułów rozszerzeń w C
40 dla Pythona, w szczególności tych utworzonych przy pomocy Cythona.
41
42 %package apidocs
43 Summary:        API documentation for Python pytest-cython module
44 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona pytest-cython
45 Group:          Documentation
46
47 %description apidocs
48 API documentation for Python pytest-cython module.
49
50 %description apidocs -l pl.UTF-8
51 Dokumentacja API modułu Pythona pytest-cython.
52
53 %prep
54 %setup -q -n pytest-cython-%{version}
55
56 %build
57 %py3_build
58
59 %if %{with tests}
60 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
61 PYTEST_PLUGINS="pytest_cython.plugin" \
62 PYTHONPATH=$(pwd)/src \
63 %{__python3} -m pytest tests/test_pytest_cython.py
64 %endif
65
66 %if %{with doc}
67 PYTHONPATH=$(pwd)/src \
68 sphinx-build-3 docs docs/build/html
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %py3_install
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc CHANGELOG.rst LICENSE README.rst
82 %{py3_sitescriptdir}/pytest_cython
83 %{py3_sitescriptdir}/pytest_cython-%{version}-py*.egg-info
84
85 %if %{with doc}
86 %files apidocs
87 %defattr(644,root,root,755)
88 %doc docs/build/html/{_static,*.html,*.js}
89 %endif
This page took 0.112212 seconds and 3 git commands to generate.