]> git.pld-linux.org Git - packages/python3-pystray.git/blob - python3-pystray.spec
rebuild with python 3.10
[packages/python3-pystray.git] / python3-pystray.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # API documentation
4 %bcond_with     tests   # unit tests, wants dbus and X11
5
6 %define         module  pystray
7 Summary:        This library allows you to create a system tray icon
8 Name:           python3-%{module}
9 Version:        0.17.3
10 Release:        3
11 License:        LGPLv3+
12 Group:          Libraries/Python
13 Source0:        https://github.com/moses-palmer/pystray/archive/v%{version}/%{module}-%{version}.tar.gz
14 # Source0-md5:  089154b1ff9c5d33b42510c18edf7cf2
15 URL:            https://github.com/moses-palmer/pystray
16 BuildRequires:  python3-modules >= 1:3.2
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with doc}
20 BuildRequires:  sphinx-pdg-3
21 %endif
22 Requires:       dbus
23 Requires:       gtk+3
24 Requires:       libappindicator-gtk3
25 Requires:       python3-modules >= 1:3.2
26 Requires:       python3-pillow
27 Requires:       python3-six
28 Requires:       python3-Xlib
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This library allows you to create a system tray icon.
34
35 %package apidocs
36 Summary:        API documentation for Python %{module} module
37 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona %{module}
38 Group:          Documentation
39
40 %description apidocs
41 API documentation for Python %{module} module.
42
43 %description apidocs -l pl.UTF-8
44 Dokumentacja API modułu Pythona %{module}.
45
46 %prep
47 %setup -q -n %{module}-%{version}
48
49 %build
50 %py3_build %{?with_tests:test}
51
52 %if %{with doc}
53 sphinx-build-3 docs docs/html
54 rm -rf docs/html/_sources
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %py3_install
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc CHANGES.rst README.rst
68 %dir %{py3_sitescriptdir}/%{module}
69 %{py3_sitescriptdir}/%{module}/*.py
70 %{py3_sitescriptdir}/%{module}/__pycache__
71 %dir %{py3_sitescriptdir}/%{module}/_util
72 %{py3_sitescriptdir}/%{module}/_util/*.py
73 %{py3_sitescriptdir}/%{module}/_util/__pycache__
74 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
75
76 %if %{with doc}
77 %files apidocs
78 %defattr(644,root,root,755)
79 %doc docs/html/*
80 %endif
This page took 0.092892 seconds and 3 git commands to generate.