]> git.pld-linux.org Git - packages/python3-pyhamcrest.git/blob - python3-pyhamcrest.spec
rebuild with python 3.10
[packages/python3-pyhamcrest.git] / python3-pyhamcrest.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4
5 Summary:        Hamcrest framework for matcher objects
6 Summary(pl.UTF-8):      Szkielet Hamcrest do obiektów dopasowujących
7 Name:           python3-pyhamcrest
8 Version:        2.0.2
9 Release:        4
10 License:        BSD
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/pyhamcrest/
13 Source0:        https://files.pythonhosted.org/packages/source/p/pyhamcrest/PyHamcrest-%{version}.tar.gz
14 # Source0-md5:  7a086f0b067f8d38958ec32f054559b4
15 URL:            https://pypi.org/project/PyHamcrest/
16 BuildRequires:  python3-modules >= 1:3.5
17 BuildRequires:  python3-setuptools
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with doc}
21 BuildRequires:  python3-sphinx_rtd_theme
22 BuildRequires:  sphinx-pdg-3
23 %endif
24 Requires:       python3-modules >= 1:3.5
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 PyHamcrest is a framework for writing matcher objects, allowing you to
30 declaratively define "match" rules. There are a number of situations
31 where matchers are invaluable, such as UI validation, or data
32 filtering, but it is in the area of writing flexible tests that
33 matchers are most commonly used.
34
35 %description -l pl.UTF-8
36 PyHamcrest to szkielet do pisania obiektów dopasowujących,
37 pozwalających deklaratywnie definiować reguły dopasowań. Jest wiele
38 sytuacji, gdzie dopasowywanie jest bezcenne, np. sprawdzanie
39 poprawności w interfejsie użytkownika, filtrowanie danych, ale
40 najczęściej jest przydatne w obszarze pisania elastycznych testów.
41
42 %package apidocs
43 Summary:        API documentation for Python pyhamcrest module
44 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona pyhamcrest
45 Group:          Documentation
46
47 %description apidocs
48 API documentation for Python pyhamcrest module.
49
50 %description apidocs -l pl.UTF-8
51 Dokumentacja API modułu Pythona pyhamcrest.
52
53 %prep
54 %setup -q -n PyHamcrest-%{version}
55
56 %build
57 %py3_build
58
59 %if %{with doc}
60 PYTHONPATH=$(pwd)/src \
61 %{__make} -C doc html \
62         SPHINXBUILD=sphinx-build-3
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %py3_install
69
70 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-pyhamcrest-%{version}
71 cp -a examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python3-pyhamcrest-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc CHANGES.txt LICENSE.txt README.rst
79 %{py3_sitescriptdir}/hamcrest
80 %{py3_sitescriptdir}/PyHamcrest-%{version}-py*.egg-info
81 %{_examplesdir}/python3-pyhamcrest-%{version}
82
83 %if %{with doc}
84 %files apidocs
85 %defattr(644,root,root,755)
86 %doc doc/_build/html/{_static,*.html,*.js}
87 %endif
This page took 0.081732 seconds and 3 git commands to generate.