]> git.pld-linux.org Git - packages/python3-pycairo.git/blob - python3-pycairo.spec
113ef03cd57548087afa29ee58059c450c90afdb
[packages/python3-pycairo.git] / python3-pycairo.spec
1 #
2 # TODO:
3 #  - check why the modules are not compiled to __pycache__
4
5 Summary:        Python 3.x Cairo bindings
6 Summary(pl.UTF-8):      Dowiązania Pythona 3.x dla Cairo
7 Name:           python3-pycairo
8 Version:        1.10.0
9 Release:        2
10 License:        LGPL v3
11 Group:          Libraries
12 Source0:        http://cairographics.org/releases/pycairo-%{version}.tar.bz2
13 # Source0-md5:  e6fd3f2f1e6a72e0db0868c4985669c5
14 URL:            http://cairographics.org/
15 BuildRequires:  cairo-devel >= 1.10.0
16 BuildRequires:  pkgconfig
17 BuildRequires:  python3 >= 3.1
18 BuildRequires:  python3-devel >= 3.1
19 # for tests only
20 #BuildRequires: python-numpy
21 # not released yet
22 #BuildRequires: python-xpyb >= 1.3
23 BuildRequires:  rpm-pythonprov
24 Requires:       cairo >= 1.10.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Python 3.x Cairo bindings.
29
30 %description -l pl.UTF-8
31 Dowiązania Pythona 3.x dla Cairo.
32
33 %package devel
34 Summary:        Development files for pycairo
35 Summary(pl.UTF-8):      Pliki programistyczne pycairo
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       cairo-devel >= 1.10.0
39
40 %description devel
41 Development files for pycairo.
42
43 %description devel -l pl.UTF-8
44 Pliki programistyczne pycairo.
45
46 %package examples
47 Summary:        Example programs using Python Cairo bindings
48 Summary(pl.UTF-8):      Przykładowe programy w Pythonie używające Cairo
49 Group:          Libraries/Python
50 Requires:       %{name} = %{version}-%{release}
51
52 %description examples
53 Example programs using Python Cairo bindings.
54
55 %description examples -l pl.UTF-8
56 Przykładowe programy w Pythonie używające Cairo.
57
58 %prep
59 %setup -q -n pycairo-%{version}
60
61 %build
62 CC="%{__cc}" \
63 CXX="%{__cxx}" \
64 CPP="%{__cpp}" \
65 CFLAGS="%{rpmcflags}" \
66 CXXFLAGS="%{rpmcxxflags}" \
67 PYTHON="%{_bindir}/python3" \
68 PYTHONDIR="%{py3_sitedir}" \
69 python3 ./waf %{?_smp_mflags} configure \
70         --libdir=%{_libdir} \
71         --prefix=%{_prefix}
72
73 python3 ./waf build
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{_examplesdir}
78
79 python3 ./waf install \
80         --destdir=$RPM_BUILD_ROOT
81
82 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS COPYING NEWS README
90 %dir %{py3_sitedir}/cairo
91 %attr(755,root,root) %{py3_sitedir}/cairo/_cairo.cpython-*.so
92 %{py3_sitedir}/cairo/*.py
93 %{py3_sitedir}/cairo/*.py[co]
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_includedir}/pycairo
98 %{_pkgconfigdir}/py3cairo.pc
99
100 %files examples
101 %defattr(644,root,root,755)
102 %{_examplesdir}/%{name}-%{version}
This page took 0.054385 seconds and 2 git commands to generate.