]> git.pld-linux.org Git - packages/python3-pluggy.git/blob - python3-pluggy.spec
rebuild with python 3.10
[packages/python3-pluggy.git] / python3-pluggy.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 %define         module  pluggy
7 Summary:        Plugin and hook calling mechanisms for Python
8 Summary(pl.UTF-8):      Mechanizmy wtyczek dla Pythona
9 Name:           python3-%{module}
10 Version:        1.0.0
11 Release:        2
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/pluggy/
15 Source0:        https://files.pythonhosted.org/packages/source/p/pluggy/pluggy-%{version}.tar.gz
16 # Source0-md5:  daa6fddfb6cd364f3c82e52098911e4b
17 URL:            https://pypi.org/project/pluggy/
18 BuildRequires:  python3-modules >= 1:3.6
19 BuildRequires:  python3-setuptools
20 BuildRequires:  python3-setuptools_scm
21 %if %{with tests}
22 %if "%{py3_ver}" < "3.8"
23 BuildRequires:  python3-importlib_metadata >= 0.12
24 %endif
25 BuildRequires:  python3-pytest >= 3.7.0
26 BuildRequires:  python3-pytest-benchmark
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.714
30 %if %{with doc}
31 BuildRequires:  python3-pygments
32 BuildRequires:  sphinx-pdg-3
33 %endif
34 Requires:       python3-modules >= 1:3.6
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Plugin manager as used by pytest but stripped of pytest specific
40 details.
41
42 %description -l pl.UTF-8
43 Zarządca wtyczek tak jak używany przez pytest, ale pozbawiony detali
44 specyficznych dla pytest.
45
46 %package apidocs
47 Summary:        API documentation for Python pluggy module
48 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona pluggy
49 Group:          Documentation
50
51 %description apidocs
52 API documentation for Python pluggy module.
53
54 %description apidocs -l pl.UTF-8
55 Dokumentacja API modułu Pythona pluggy.
56
57 %prep
58 %setup -q -n %{module}-%{version}
59
60 %build
61 %py3_build
62
63 %if %{with tests}
64 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
65 PYTHONPATH=$(pwd)/src \
66 %{__python3} -m pytest testing
67 %endif
68
69 %if %{with doc}
70 PYTHONPATH="$PWD/src" \
71 sphinx-build-3 -b html docs docs/_build/html
72 %endif
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %py3_install
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc CHANGELOG.rst LICENSE README.rst
85 %{py3_sitescriptdir}/pluggy
86 %{py3_sitescriptdir}/pluggy-%{version}-py*.egg-info
87
88 %if %{with doc}
89 %files apidocs
90 %defattr(644,root,root,755)
91 %doc docs/_build/html/{_modules,_static,*.html,*.js}
92 %endif
This page took 0.061518 seconds and 3 git commands to generate.