]> git.pld-linux.org Git - packages/python3-packaging.git/blob - python3-packaging.spec
9a6a36ffe1d77bc2bdb5418876fb6924f80af159
[packages/python3-packaging.git] / python3-packaging.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # don't build doc
4 %bcond_without  tests           # py.test tests
5 %bcond_without  setuptools      # build without setuptools (for bootstraping)
6
7 Summary:        Core utilities for Python packages
8 Summary(pl.UTF-8):      Bazowe funkcje narzędziowe do pakietów Pythona
9 Name:           python3-packaging
10 Version:        21.3
11 Release:        1
12 License:        Apache v2.0 or BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/packaging/
15 Source0:        https://files.pythonhosted.org/packages/source/p/packaging/packaging-%{version}.tar.gz
16 # Source0-md5:  e713c1939f294fd729af4a7be40dd141
17 URL:            https://github.com/pypa/packaging
18 BuildRequires:  python3-modules >= 1:3.6
19 %{?with_setuptools:BuildRequires:       python3-setuptools}
20 %if %{with tests}
21 BuildRequires:  python3-pretend
22 BuildRequires:  python3-pyparsing >= 2.0.2
23 BuildRequires:  python3-pytest
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 %if %{with doc}
28 BuildRequires:  python3-furo
29 BuildRequires:  python3-sphinx_rtd_theme
30 BuildRequires:  sphinx-pdg-3
31 %endif
32 Requires:       python3-modules >= 1:3.6
33 %if %{without setuptools}
34 # with setuptools these are autogenerated
35 Requires:       python3-pyparsing >= 2.0.2
36 %endif
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Core utilities for Python packages.
42
43 %description -l pl.UTF-8
44 Bazowe funkcje narzędziowe do pakietów Pythona.
45
46 %package apidocs
47 Summary:        API documentation for Python packaging library
48 Summary(pl.UTF-8):      Dokumentacja API biblioteki Pythona packaging
49 Group:          Documentation
50
51 %description apidocs
52 API documentation for Python packaging library.
53
54 %description apidocs -l pl.UTF-8
55 Dokumentacja API biblioteki Pythona packaging.
56
57 %prep
58 %setup -q -n packaging-%{version}
59
60 %build
61 %py3_build
62
63 %{?with_tests:%{__python3} -m pytest}
64
65 %if %{with doc}
66 %{__make} -C docs html \
67         SPHINXBUILD=sphinx-build-3
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %py3_install
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CHANGELOG.rst LICENSE LICENSE.BSD README.rst
81 %{py3_sitescriptdir}/packaging
82 %{py3_sitescriptdir}/packaging-%{version}-py*.egg-info
83
84 %if %{with doc}
85 %files apidocs
86 %defattr(644,root,root,755)
87 %doc docs/_build/html/{_static,development,*.html,*.js}
88 %endif
This page took 0.101051 seconds and 2 git commands to generate.