]> git.pld-linux.org Git - packages/python3-numpydoc.git/blob - python3-numpydoc.spec
b952200d2d26f8e9eb2e7b872b70c6edadf63160
[packages/python3-numpydoc.git] / python3-numpydoc.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Sphinx extension to support docstrings in Numpy format
8 Summary(pl.UTF-8):      Rozszerzenie Sphinksa do obsług docstringów w formacie Numpy
9 Name:           python3-numpydoc
10 Version:        1.1.0
11 Release:        2
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/numpydoc/
15 Source0:        https://files.pythonhosted.org/packages/source/n/numpydoc/numpydoc-%{version}.tar.gz
16 # Source0-md5:  2f05c4592e007b7a1fa37ddcb7e0e91b
17 URL:            https://pypi.org/project/numpydoc/
18 BuildRequires:  python3-modules >= 1:3.5
19 BuildRequires:  python3-setuptools
20 %if %{with tests}
21 BuildRequires:  python3-Sphinx >= 1.6.5
22 BuildRequires:  python3-jinja2 >= 2.3
23 BuildRequires:  python3-pluggy
24 BuildRequires:  python3-py
25 BuildRequires:  python3-pytest
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 Requires:       python3-modules >= 1:3.5
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This package provides the numpydoc Sphinx extension for handling
35 docstrings formatted according to the NumPy documentation format. The
36 extension also adds the code description directives "np:function",
37 "np-c:function", etc.
38
39 %description -l pl.UTF-8
40 Ten pakiet zawiera rozszerzenie Sphinksa do obsługi docstringów
41 sformatowanych zgodnie z formatem dokumentacji NumPy. Rozszerzenie
42 dodaje także dyrektywy opisu kodu "np:function", "np-c:function" itp.
43
44 %prep
45 %setup -q -n numpydoc-%{version}
46
47 %build
48 %py3_build
49
50 %if %{with tests}
51 %{__python3} -m pytest numpydoc/tests
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %py3_install
58
59 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/numpydoc/tests
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %if %{with python2}
65 %files
66 %defattr(644,root,root,755)
67 %doc LICENSE.txt README.rst
68 %{py3_sitescriptdir}/numpydoc
69 %{py3_sitescriptdir}/numpydoc-%{version}-py*.egg-info
70 %endif
This page took 0.070583 seconds and 2 git commands to generate.