]> git.pld-linux.org Git - packages/python3-nptyping.git/blob - python3-nptyping.spec
- new
[packages/python3-nptyping.git] / python3-nptyping.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        Type hints for NumPy
6 Summary(pl.UTF-8):      Podpowiedzi typów dla NumPy
7 Name:           python3-nptyping
8 Version:        2.5.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/nptyping/
13 Source0:        https://files.pythonhosted.org/packages/source/n/nptyping/nptyping-%{version}.tar.gz
14 # Source0-md5:  08bddbff6a31f7e42d59ec1d4819d0e5
15 URL:            https://pypi.org/project/nptyping/
16 BuildRequires:  python3-modules >= 1:3.7
17 BuildRequires:  python3-setuptools
18 %if %{with tests}
19 #TODO: beartype>=0.10.0 (for 3.10+), mypy, pyright, typeguard
20 BuildRequires:  python3-feedparser
21 BuildRequires:  python3-invoke >= 1.6.0
22 BuildRequires:  python3-numpy >= 1.20.0
23 BuildRequires:  python3-pandas
24 BuildRequires:  python3-typing_extensions >= 4
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       python3-modules >= 1:3.7
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 - type hints for NumPy
34 - type hints for pandas.DataFrame
35 - extensive dynamic type checks for dtypes shapes and structures
36
37 %description -l pl.UTF-8
38 - podpowiedzi typów dla NumPy
39 - podpowiedzi typów dla pandas.DataFrame
40 - rozszerzone dynamiczne sprawdzanie typów dla form i struktur dtype
41
42 %prep
43 %setup -q -n nptyping-%{version}
44
45 # requires beartype (TODO)
46 %{__rm} tests/test_beartype.py
47 # requires mypy (TODO)
48 %{__rm} tests/test_mypy.py tests/pandas_/test_mypy_dataframe.py
49 # for author (before release)
50 %{__rm} tests/test_package_info.py
51 # requires pyright (TODO)
52 %{__rm} tests/test_pyright.py
53 # pip manipulation
54 %{__rm} tests/test_wheel.py
55 # requires typeguard (TODO)
56 %{__rm} tests/test_typeguard.py
57 # no pandas 1.5.x in PLD yet
58 %{__rm} tests/pandas_/test_fork_sync.py
59 # requires mypy (TODO)
60 %{__rm} tests/test_helpers/check_mypy_on_code.py
61
62 %build
63 %py3_build
64
65 %if %{with tests}
66 %{__python3} -m unittest discover -s tests
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %py3_install
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc HISTORY.md LICENSE README.md USERDOCS.md
80 %{py3_sitescriptdir}/nptyping
81 %{py3_sitescriptdir}/nptyping-%{version}-py*.egg-info
This page took 0.094702 seconds and 3 git commands to generate.