]> git.pld-linux.org Git - packages/python3-more_itertools.git/blob - python3-more_itertools.spec
rebuild with tests and docs
[packages/python3-more_itertools.git] / python3-more_itertools.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 Summary:        More routines for operating on iterables, beyond itertools
7 Summary(pl.UTF-8):      Uzupełniające itertools dodatkowe funkcje do operowania na zmiennych iterowalnych
8 Name:           python3-more_itertools
9 Version:        8.12.0
10 Release:        3
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/more-itertools/
14 Source0:        https://files.pythonhosted.org/packages/source/m/more_itertools/more-itertools-%{version}.tar.gz
15 # Source0-md5:  81687cb0c6cd178390b069d81b4e6672
16 URL:            https://github.com/erikrose/more-itertools
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 %if %{with doc}
22 BuildRequires:  python3-sphinx_rtd_theme
23 BuildRequires:  sphinx-pdg-3
24 %endif
25 Requires:       python3-modules >= 1:3.6
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Python's itertools library is a gem - you can compose elegant
31 solutions for a variety of problems with the functions it provides. In
32 more-itertools we collect additional building blocks, recipes, and
33 routines for working with Python iterables.
34
35 %description -l pl.UTF-8
36 Biblioteka Pythona itertools to skarb - przy użyciu udostępnianych
37 funkcji można komponować eleganckie rozwiązania różnych problemów.
38 W pakiecie more-itertools zebrane są dodatkowe elementy konstrukcyjne,
39 przepisy i procedury do pracy z pythonowymi zmiennymi iterowalnymi.
40
41 %package apidocs
42 Summary:        API documentation for Python more-itertools module
43 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona more-itertools
44 Group:          Documentation
45
46 %description apidocs
47 API documentation for Python more-itertools module.
48
49 %description apidocs -l pl.UTF-8
50 Dokumentacja API modułu Pythona more-itertools.
51
52 %prep
53 %setup -q -n more-itertools-%{version}
54
55 %build
56 %py3_build
57
58 %if %{with tests}
59 %{__python3} -m unittest discover -s tests
60 %endif
61
62 %if %{with doc}
63 PYTHONPATH=$(pwd) \
64 %{__make} -C docs html \
65         SPHINXBUILD=sphinx-build-3
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %py3_install
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc LICENSE README.rst
79 %{py3_sitescriptdir}/more_itertools
80 %{py3_sitescriptdir}/more_itertools-%{version}-py*.egg-info
81
82 %if %{with doc}
83 %files apidocs
84 %defattr(644,root,root,755)
85 %doc docs/_build/html/{_modules,_static,*.html,*.js}
86 %endif
This page took 0.071813 seconds and 3 git commands to generate.