]> git.pld-linux.org Git - packages/python3-mdurl.git/blob - python3-mdurl.spec
- updated to 0.1.2
[packages/python3-mdurl.git] / python3-mdurl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4
5 Summary:        Markdown URL utilities
6 Summary(pl.UTF-8):      Narzędzia do URL-i w formacie Markdown
7 Name:           python3-mdurl
8 Version:        0.1.2
9 Release:        1
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/mdurl/
13 Source0:        https://files.pythonhosted.org/packages/source/m/mdurl/mdurl-%{version}.tar.gz
14 # Source0-md5:  f18eca6522b438354be2378f216a5a94
15 URL:            https://pypi.org/project/mdurl/
16 BuildRequires:  python3-modules >= 1:3.7
17 BuildRequires:  python3-setuptools >= 1:61
18 # TODO:
19 #BuildRequires: python3-flit_core >= 3.2.0
20 %if %{with tests}
21 BuildRequires:  python3-pytest
22 BuildRequires:  python3-pytest-randomly
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 Requires:       python3-modules >= 1:3.7
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 URL utilities for markdown-it parser.
32
33 %description -l pl.UTF-8
34 Narzędzia do URL-i dla parsera markdown-it.
35
36 %prep
37 %setup -q -n mdurl-%{version}
38
39 # setuptools stub
40 cat >setup.py <<EOF
41 from setuptools import setup
42 setup()
43 EOF
44
45 %build
46 %py3_build
47
48 %if %{with tests}
49 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
50 PYTEST_PLUGINS="pytest_randomly" \
51 %{__python3} -m pytest tests
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %py3_install
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc LICENSE README.md
65 %{py3_sitescriptdir}/mdurl
66 %{py3_sitescriptdir}/mdurl-%{version}-py*.egg-info
This page took 0.086697 seconds and 3 git commands to generate.