]> git.pld-linux.org Git - packages/python3-markdown-it-py.git/blob - python3-markdown-it-py.spec
4b31b4d00f847ca76250c1ff9ebd822ccd82d30f
[packages/python3-markdown-it-py.git] / python3-markdown-it-py.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4
5 Summary:        Python port of markdown-it: Markdown parsing, done right
6 Summary(pl.UTF-8):      Pythonowy port markdown-it: analiza Markdown zrobiona dobrze
7 Name:           python3-markdown-it-py
8 Version:        2.0.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/markdown-it-py/
13 Source0:        https://files.pythonhosted.org/packages/source/m/markdown-it-py/markdown-it-py-%{version}.tar.gz
14 # Source0-md5:  15d36cd4a26e0febe09f8661fd487167
15 URL:            https://pypi.org/project/markdown-it-py/
16 BuildRequires:  python3-modules >= 1:3.6
17 BuildRequires:  python3-setuptools >= 1:46.4.0
18 %if %{with tests}
19 BuildRequires:  python3-attrs >= 19
20 BuildRequires:  python3-mdurl >= 0.1
21 BuildRequires:  python3-pytest
22 BuildRequires:  python3-pytest-cov
23 BuildRequires:  python3-pytest-regressions
24 %if "%{py3_ver}" < "3.8"
25 BuildRequires:  python3-typing_extensions >= 3.7.4
26 %endif
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.714
30 BuildRequires:  sed >= 4.0
31 Requires:       python3-modules >= 1:3.6
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This is a Python port of markdown-it, and some of its associated
37 plugins.
38
39 %description -l pl.UTF-8
40 Ten pakiet to pythonowy port projektu markdown-it i kilku powiÄ…zanych
41 wtyczek.
42
43 %prep
44 %setup -q -n markdown-it-py-%{version}
45
46 %{__sed} -i -e '/mdurl/ s/~=/>=/' setup.cfg
47
48 %build
49 %py3_build
50
51 %if %{with tests}
52 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
53 %{__python3} -m pytest tests
54 %endif
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %py3_install
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc CHANGELOG.md LICENSE LICENSE.markdown-it README.md
67 %attr(755,root,root) %{_bindir}/markdown-it
68 %{py3_sitescriptdir}/markdown_it
69 %{py3_sitescriptdir}/markdown_it_py-%{version}-py*.egg-info
This page took 0.025689 seconds and 2 git commands to generate.