]> git.pld-linux.org Git - packages/python3-kombu.git/blob - python3-kombu.spec
43894ef446ddd3bba0ca21141e78c023254c7011
[packages/python3-kombu.git] / python3-kombu.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 %define         module  kombu
7 Summary:        Messaging library for Python
8 Summary(pl.UTF-8):      Biblioteka komunikatów dla Pythona
9 Name:           python3-%{module}
10 Version:        5.0.2
11 Release:        2
12 License:        BSD
13 Group:          Development/Languages/Python
14 #Source0Download: https://pypi.org/simple/kombu/
15 Source0:        https://files.pythonhosted.org/packages/source/k/kombu/%{module}-%{version}.tar.gz
16 # Source0-md5:  52192e631ac39a443fb1abeb52299f22
17 URL:            https://pypi.org/project/kombu/
18 BuildRequires:  python3-modules >= 1:3.6
19 BuildRequires:  python3-setuptools >= 1:20.6.7
20 %if %{with tests}
21 BuildRequires:  python3-Pyro4
22 BuildRequires:  python3-amqp >= 5.0.0
23 BuildRequires:  python3-amqp < 6.0.0
24 BuildRequires:  python3-botocore
25 BuildRequires:  python3-case >= 1.5.2
26 %if "%{py3_ver}" < "3.8"
27 BuildRequires:  python3-importlib_metadata >= 0.18
28 %endif
29 BuildRequires:  python3-pytest
30 BuildRequires:  python3-pytz
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 %if %{with doc}
35 BuildRequires:  python3-amqp
36 BuildRequires:  python3-sphinx_celery
37 BuildRequires:  sphinx-pdg-3
38 %endif
39 Requires:       python3-modules >= 1:3.6
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 The aim of Kombu is to make messaging in Python as easy as possible by
45 providing an idiomatic high-level interface for the AMQ protocol, and
46 also provide proven and tested solutions to common messaging problems.
47
48 %description -l pl.UTF-8
49 Celem Kombu jest jak największe ułatwienie wymiany komunikatów w
50 Pythonie poprzez dostarczenie idomatycznego, wysokopoziomowego
51 interfejsu do protokołu AMQ oraz sprawdzonych rozwiązań powszechnych
52 problemów związanych z komunikowaniem.
53
54 %package apidocs
55 Summary:        API documentation for kombu module
56 Summary(pl.UTF-8):      Dokumentacja API modułu kombu
57 Group:          Documentation
58
59 %description apidocs
60 API documentation for kombu module.
61
62 %description apidocs -l pl.UTF-8
63 Dokumentacja API modułu kombu.
64
65 %prep
66 %setup -q -n %{module}-%{version}
67
68 %build
69 %py3_build
70
71 %if %{with tests}
72 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
73 PYTEST_PLUGINS="case.pytest" \
74 %{__python3} -m pytest t/unit
75 %endif
76
77 %if %{with doc}
78 %{__make} -C docs html \
79         SPHINXBUILD=sphinx-build-3
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %py3_install
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS FAQ LICENSE README.rst THANKS TODO
93 %{py3_sitescriptdir}/%{module}
94 %{py3_sitescriptdir}/%{module}-*.egg-info
95
96 %if %{with doc}
97 %files apidocs
98 %defattr(644,root,root,755)
99 %doc docs/_build/html/{_modules,_static,reference,userguide,*.html,*.js}
100 %endif
This page took 0.058126 seconds and 2 git commands to generate.