]> git.pld-linux.org Git - packages/python3-jeepney.git/blob - python3-jeepney.spec
rebuild with tests and docs
[packages/python3-jeepney.git] / python3-jeepney.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 Summary:        Low-level, pure Python DBus protocol wrapper
7 Summary(pl.UTF-8):      Niskopoziomowe obudowanie protokołu DBus w czystym Pythonie
8 Name:           python3-jeepney
9 Version:        0.7.1
10 Release:        3
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/jeepney/
14 Source0:        https://files.pythonhosted.org/packages/source/j/jeepney/jeepney-%{version}.tar.gz
15 # Source0-md5:  d804ad938b27d9b761f2c44f8d33fef6
16 URL:            https://pypi.org/project/jeepney/
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-async_timeout
21 BuildRequires:  python3-pytest
22 BuildRequires:  python3-pytest-asyncio
23 BuildRequires:  python3-pytest-trio
24 BuildRequires:  python3-testpath
25 BuildRequires:  python3-trio
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 %if %{with doc}
30 BuildRequires:  sphinx-pdg-3
31 %endif
32 Requires:       python3-modules >= 1:3.6
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This is a low-level, pure Python DBus protocol client. It has an
38 I/O-free core, and integration modules for different event loops.
39
40 DBus is an inter-process communication system, mainly used in Linux.
41
42 %description -l pl.UTF-8
43 Jeepney to niskopoziomowy, napisany w czystym Pythonie klient
44 protokołu DBus. Wewnętrznie jest oparty na podejściu I/O-free, ma
45 moduły integrujące dla różnych pętli zdarzeń.
46
47 DBus to system komunikacji międzyprocesowej, używany głównie na
48 Linuksie.
49
50 %package apidocs
51 Summary:        jeepney API documentation
52 Summary(pl.UTF-8):      Dokumentacja API jeepney
53 Group:          Documentation
54
55 %description apidocs
56 API documentation for jeepney.
57
58 %description apidocs -l pl.UTF-8
59 Dokumentacja API jeepney.
60
61 %prep
62 %setup -q -n jeepney-%{version}
63
64 %build
65 %py3_build
66
67 %if %{with tests}
68 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
69 PYTEST_PLUGINS="pytest_asyncio.plugin,pytest_trio.plugin" \
70 %{__python3} -m pytest jeepney/tests jeepney/*/tests
71 %endif
72
73 %if %{with doc}
74 %{__make} -C docs html \
75         SPHINXBUILD=sphinx-build-3
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %py3_install
82
83 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/jeepney{,/io,/integrate}/tests
84
85 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86 cp -a examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc LICENSE README.rst
94 %{py3_sitescriptdir}/jeepney
95 %{py3_sitescriptdir}/jeepney-%{version}-py*.egg-info
96 %{_examplesdir}/%{name}-%{version}
97
98 %if %{with doc}
99 %files apidocs
100 %defattr(644,root,root,755)
101 %doc docs/_build/html/{_modules,_static,*.html,*.js}
102 %endif
This page took 0.105622 seconds and 3 git commands to generate.