]> git.pld-linux.org Git - packages/python3-itsdangerous.git/blob - python3-itsdangerous.spec
6d9f09d1bd85d5e49b36fdb12b45cb5d0db6c63d
[packages/python3-itsdangerous.git] / python3-itsdangerous.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 %define         module  itsdangerous
7 Summary:        Various helpers to pass trusted data to untrusted environments and back
8 Summary(pl.UTF-8):      Wspomaganie przekazywania danych do i z niezaufanych środowisk
9 Name:           python3-%{module}
10 Version:        2.0.1
11 Release:        2
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/itsdangerous
15 Source0:        https://pypi.python.org/packages/source/i/itsdangerous/%{module}-%{version}.tar.gz
16 # Source0-md5:  996b9763d1b4bd0edd6eb86f0a490629
17 URL:            http://github.com/mitsuhiko/itsdangerous
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 BuildRequires:  python3-modules >= 1:3.6
21 BuildRequires:  python3-setuptools
22 %if %{with tests}
23 BuildRequires:  python3-freezegun
24 BuildRequires:  python3-pytest
25 %endif
26 %if %{with doc}
27 BuildRequires:  python3-pallets-sphinx-themes >= 1.1.0
28 BuildRequires:  sphinx-pdg-3 >= 1.8.0
29 %endif
30 Requires:       python-modules >= 1:2.7
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Various helpers to pass data to untrusted environments and to get it
36 back safe and sound.
37
38 %description -l pl.UTF-8
39 Funkcje pomocnicze do przekazywania danych do niezaufanych środowisk i
40 pobierania ich w sposób bezpieczny.
41
42 %package apidocs
43 Summary:        Documentation for Python itsdangerous module
44 Summary(pl.UTF-8):      Dokumentacja do moduły Pythona itsdangerous
45 Group:          Documentation
46
47 %description apidocs
48 Documentation for Python itsdangerous module.
49
50 %description apidocs -l pl.UTF-8
51 Dokumentacja do moduły Pythona itsdangerous.
52
53 %prep
54 %setup -q -n %{module}-%{version}
55
56 %build
57 %py3_build
58
59 %if %{with tests}
60 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
61 PYTHONPATH=$(pwd)/src \
62 %{__python3} -m pytest tests
63 %endif
64
65 %if %{with doc}
66 PYTHONPATH=$(pwd)/src \
67 %{__make} -C docs html
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %py3_install
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CHANGES.rst LICENSE.rst README.rst
81 %{py3_sitescriptdir}/itsdangerous
82 %{py3_sitescriptdir}/itsdangerous-%{version}-py*.egg-info
83
84 %if %{with doc}
85 %files apidocs
86 %defattr(644,root,root,755)
87 %doc docs/_build/html/{_static,*.html,*.js}
88 %endif
This page took 0.094778 seconds and 2 git commands to generate.