]> git.pld-linux.org Git - packages/python3-idna.git/blob - python3-idna.spec
rebuild with python 3.10
[packages/python3-idna.git] / python3-idna.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         module  idna
6 Summary:        Internationalized Domain Names in Applications (IDNA) for Python 2
7 Summary(pl.UTF-8):      IDNA (Internationalized Domain Names in Applications) dla Pythona 2
8 Name:           python3-%{module}
9 Version:        3.3
10 Release:        2
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://github.com/kjd/idna/releases
14 Source0:        https://github.com/kjd/idna/archive/v%{version}/%{module}-%{version}.tar.gz
15 # Source0-md5:  ce91a53442503d8e94b869957b7d4981
16 URL:            https://github.com/kjd/idna
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 BuildRequires:  python3-modules >= 1:3.6
20 BuildRequires:  python3-setuptools
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A library to support the Internationalised Domain Names in
26 Applications (IDNA) protocol as specified in RFC 5891. This version of
27 the protocol is often referred to as IDNA2008 and can produce
28 different results from the earlier standard from 2003.
29
30 The library is also intended to act as a suitable drop-in replacement
31 for the encodings.idna module that comes with the Python standard
32 library but currently only supports the older 2003 specification.
33
34 %description -l pl.UTF-8
35 Biblioteka obsługująca protokół IDNA (International Domain Names in
36 Applications - międzynarodowe nazwy domen w aplikacjach) według
37 specyfikacji RFC 5891. Ta wersja protokołu jest często nazywana
38 IDNA2008 i może dawać inne wyniki, niż wcześniejszy standard z 2003
39 roku.
40
41 Ta biblioteka ma służyć także jako zamiennik modułu encodings.idna
42 dostarczanego z biblioteką standardową Pythona, ale obecnie
43 obsługująca tylko starszą specyfikację z 2003.
44
45 %prep
46 %setup -q -n %{module}-%{version}
47
48 %build
49 %py3_build %{?with_tests:test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %py3_install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc HISTORY.rst LICENSE.md README.rst
62 %{py3_sitescriptdir}/%{module}
63 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.098964 seconds and 3 git commands to generate.