]> git.pld-linux.org Git - packages/python3-hypothesis.git/blob - python3-hypothesis.spec
42bc38d22cad8e7c5033ef7ecaded305a1845a2a
[packages/python3-hypothesis.git] / python3-hypothesis.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # nothing currently
4
5 Summary:        Hypothesis - library for property based testing
6 Summary(pl.UTF-8):      Hypothesis - biblioteka do testowania opartego na własnościach
7 Name:           python3-hypothesis
8 Version:        5.49.0
9 Release:        2
10 License:        MPL v2.0
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/hypothesis/
13 Source0:        https://files.pythonhosted.org/packages/source/h/hypothesis/hypothesis-%{version}.tar.gz
14 # Source0-md5:  350fda2e928cc59a38160d9c72f3631c
15 URL:            https://github.com/DRMacIver/hypothesis
16 BuildRequires:  python3-modules >= 1:3.6
17 BuildRequires:  python3-setuptools >= 1:36.2
18 %if %{with tests}
19 BuildRequires:  python3-attrs >= 19.2.0
20 BuildRequires:  python3-sortedcontainers >= 2.1.0
21 BuildRequires:  python3-sortedcontainers < 3.0.0
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 Requires:       python3-modules >= 1:3.6
26 # for individual -extras modules:
27 #Suggests:      python3-dateutil >= 1.4
28 #Suggests:      python3-django >= 2.2
29 #Suggests:      python3-dpcontracts >= 0.4
30 #Suggests:      python3-lark-parser >= 0.6.5
31 #Suggests:      python3-numpy >= 1.9.0
32 #Suggests:      python3-pandas >= 0.25
33 #Suggests:      python3-pytest >= 4.3
34 #Suggests:      python3-pytz >= 2014.1
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Hypothesis is a library for testing your Python code against a much
40 larger range of examples than you would ever want to write by hand.
41 It's based on the Haskell library, Quickcheck, and is designed to
42 integrate seamlessly into your existing Python unit testing work flow.
43
44 %description -l pl.UTF-8
45 Hypothesis to biblioteka do testowania kodu w Pythonie względem dużo
46 większej liczby przykładów, niż kiedykolwiek chciałoby się pisać
47 ręcznie. Jest oparta na bibliotece Quickcheck języka Haskell i została
48 zaprojektowana tak, aby w sposób przezroczysty integrowała się z
49 istniejącym przepływem testów jednostkowych w Pythonie.
50
51 %prep
52 %setup -q -n hypothesis-%{version}
53
54 %build
55 %py3_build
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %py3_install
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README.rst
68 %attr(755,root,root) %{_bindir}/hypothesis
69 %{py3_sitescriptdir}/hypothesis
70 %{py3_sitescriptdir}/hypothesis-%{version}-py*.egg-info
This page took 0.359641 seconds and 2 git commands to generate.