]> git.pld-linux.org Git - packages/python3-humanize.git/blob - python3-humanize.spec
rebuild with python 3.10
[packages/python3-humanize.git] / python3-humanize.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        Python 3 humanize utilities
6 Summary(pl.UTF-8):      Narzędzia Pythona 3 humanize
7 Name:           python3-humanize
8 Version:        2.0.0
9 Release:        3
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/humanize/
13 Source0:        https://files.pythonhosted.org/packages/source/h/humanize/humanize-%{version}.tar.gz
14 # Source0-md5:  65b289c0ec1a76a1d572aebc7cfed96f
15 URL:            https://pypi.org/project/humanize/
16 BuildRequires:  python3-modules >= 1:3.5
17 BuildRequires:  python3-setuptools
18 BuildRequires:  python3-setuptools_scm
19 %if %{with tests}
20 BuildRequires:  python3-freezegun
21 BuildRequires:  python3-pytest
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 Requires:       python3-modules >= 1:3.5
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This modest package contains various common humanization utilities,
31 like turning a number into a fuzzy human readable duration ('3 minutes
32 ago') or into a human readable size or throughput.
33
34 %description -l pl.UTF-8
35 Ten skromny pakiet zawiera różne narzędzia do ogólnej poprawy
36 interakcji z ludźmi - jak zamiana liczby na przybliżoną formę czytelną
37 dla człowieka ("3 minuty temu") albo czytelny dla człowieka rozmiar
38 czy przepustowość.
39
40 %prep
41 %setup -q -n humanize-%{version}
42
43 %build
44 %py3_build
45
46 %if %{with tests}
47 PYTHONPATH=$(pwd)/src \
48 %{__python3} -m pytest tests
49 %endif
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %py3_install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc LICENCE README.md
62 %{py3_sitescriptdir}/humanize
63 %{py3_sitescriptdir}/humanize-%{version}-py*.egg-info
This page took 0.07434 seconds and 3 git commands to generate.